some WebM videos in YouTube are jerky

RESOLVED DUPLICATE of bug 1210726

Status

()

defect
P3
normal
Rank:
29
RESOLVED DUPLICATE of bug 1210726
8 years ago
2 months ago

People

(Reporter: jhorak, Unassigned)

Tracking

11 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Youtube])

From: https://bugzilla.redhat.com/show_bug.cgi?id=756569
Description of problem:
Some WebM videos in YouTube are jerky.  The following video is an example:

http://www.youtube.com/watch?v=7rljVIVHT6o

If I download the video with youtube-dl and play it with totem, it is not
jerky.

I have also seen some other WebM videos in YouTube which are not jerky.

How reproducible:
Happens every time.

Steps to Reproduce:
1.  Start Firefox.
2.  Go to http://www.youtube.com/watch?v=7rljVIVHT6o 
3.  Play video.

Actual results:
The video is jerky.

Expected results:
The video should be smooth.

Additional info:
The audio is OK.
This problem still persists on a build with the bug 736342 fixes in it. It can also be observed outside of YouTube, and without audio. See http://media.basilgohar.com/nasa/perpetual-ocean/perpetual-ocean_432p30.webm for a good example (this video is much more computationally demanding than the YouTube link given, but I can still observe long stalls while the CPU usage is well below 100%).
Thanks for filing jhorak, I've been trying to solve this issue, but can't reliably reproduce it locally.

We'll also need to wait for bug 725993's fixes to lands to eliminate the possibility of main-thread file IO causing jank here. Perhaps once bug 725993 lands in nightly builds you could test the nightly build to see if this still occurs?
(In reply to Chris Pearce (:cpearce) from comment #2)
> We'll also need to wait for bug 725993's fixes to lands to eliminate the
> possibility of main-thread file IO causing jank here. Perhaps once bug
> 725993 lands in nightly builds you could test the nightly build to see if
> this still occurs?

I applied the patch in bug 725993 (with a couple of bitrot fixes), but can still observe occasional stalls (some a second or two long) playing both the videos mentioned in this bug (in a Firefox instance with no other tabs open).
Does anyone know why this issue occurs with the radeon r600 driver but not with the intel driver?
This bug seems to be fixed when using the Live Image from the Fedora 19 Test Day.

https://fedoraproject.org/wiki/Test_Day:2013-04-25_Radeon
I have tested further with Fedora 19.  I believe that the bug that I originally reported downstream (which seemed to occur with Radeon GPUs only) has been fixed.  

However, there are apparently other issues affecting HTML5 video performance.  The YouTube video referenced in Comment 0 is less jerky but still seems to have a poor frame rate:

Presented Frames = 3475
Painted Frames = 1341

I remember that the Red Hat Summit 2013 videos (at http://www.redhat.com/summit) played poorly in Fedora 18.  The same videos play well in Fedora 19.
After troubleshooting this issue some more, I found that the problem went away after the Operator extension was disabled.
Now that YouTube is showing off 60fps videos, this could do with some more attention ‐ I’m seeing about 2 frames in 3 not even being presented for this clip in 1080p, with high motion scenes having fps in the spf range. https://www.youtube.com/watch?v=T3ny9zIckP0 for BF:Hardline (excuse the fictional violence)
Component: Audio/Video → Audio/Video: Playback
Is this issue still reproducible?
Flags: needinfo?(jhorak)
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]
Reported issue is fine, I'm having similar tearing as mentioned in comment 8, but that probably missing acceleration in Linux in my case.
Flags: needinfo?(jhorak)
platform-rel: ? → ---
ALL youtube videos are jerky on my Windows 10 Dell 9020 mid tower, and on my Dell T500 Windows 7 laptop.  It was also true of my Dell 990 Windows 7 machine before it died.  The videos always play fine in both Microsoft Edge and in Google Chrome.  This has been the case for at least over a year.
Rank: 29
Priority: -- → P3

(Jan Horak [:jhorak] from comment #10)

Reported issue is fine, I'm having similar tearing as mentioned in comment 8, but that probably missing acceleration in Linux in my case.

Previous "OpenGL" compositing (bug 594876) is now being replaced by WebRender.
On Nightly, WebRender is already enabled by default for modern Intel and AMD with Mesa 18.2 or newer with screens smaller than 4K.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210726
You need to log in before you can comment on or make changes to this bug.