Closed Bug 1210726 Opened 5 years ago Closed 4 months ago

[meta] Add hardware playback capabilities on Linux

Categories

(Core :: Audio/Video: Playback, task, P3)

Unspecified
Linux
task

Tracking

()

RESOLVED DUPLICATE of bug 1580166

People

(Reporter: jya, Unassigned)

References

(Depends on 3 open bugs)

Details

(Keywords: meta)

This bug will track support for hardware decoding on Linux and the various system available (VA-API, VDPAU, DXVA and others)

There's so many frameworks available, it's hard to keep track!
Depends on: 1210727
Depends on: 1210729
OS: Unspecified → Linux
Version: 43 Branch → 1.0 Branch
No longer blocks: MSE
(In reply to sheepdestroyer from comment #4)
> Is there a reason the priority would go from P2 to P3?

We were using P1, P2 and P5. Now we're using P1, P3 and P5. The priority hasn't changed.

> Lack of hardware acceleration is the worse offender on Linux right now.

How did you come to that conclusion?

The following things are more important:

* Basic layers is slow in 47; much better in 48
* GL Layers isn't enabled yet
* WebGL does readback (only affects 360)

Even if you enable H.264 hardware decoding you miss out on the network performance (better compression) of VP9. If you fix the above issues then most users will be network constrained by a significant margin.

> Some youtube videos can not even play at a decent framerate because of that,
> especially the 4K / 360 ones. And that's without speaking of the heat
> generated by those poor CPUs...

You may be barking up the wrong tree. Consider that what you're really after is better video performance. Most CPUs that have struggle to decode video don't have working VA-API. 

> I do not get why it would not even go the other way, right to P1 ?

P1 is mostly used for security, crash, regression and significant webcompat issues. P3 is for backlog which is everything else that matters.
Gentle reminders:

* Our guidelines ask you don't argue about priority setting on bugs. Triage leads and Mozillians working on the bug set the priority. See: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
* This is not the place to discuss general Linux workarounds not specific to this bug. 

Extended, off-topic comments on a bug add noise to the signal. Per, https://bugzilla.mozilla.org/page.cgi?id=restrict_comments_guidelines.html, we've restricted comments on this bug to Mozillians with EDITBUGS permissions. 

If you can contribute to the resolution of this, or other bugs, please request EDITBUGS permissions. See https://bugzilla.mozilla.org/page.cgi?id=get_permissions.html for more information.
Flags: needinfo?(mhoye)
See Also: → 1306529
Flags: needinfo?(mhoye)
Assignee: jyavenard → nobody
Duplicate of this bug: 1416444
Duplicate of this bug: 1543500
Type: defect → task
Version: 1.0 Branch → Trunk
Depends on: wr-linux
No longer depends on: ogl-linux-beta
Duplicate of this bug: 563206
Duplicate of this bug: 1280771
Duplicate of this bug: 740342
Duplicate of this bug: 1336810
Duplicate of this bug: 1540976
Duplicate of this bug: 495727

Is there code that can be pulled from Servo? https://github.com/servo/servo/pull/23483

Servo's media stack is very different, and all of the actual hardware decoding comes from gstreamer internals. That pull request is just the plumbing required to provide the data the gstreamer requires to work in Servo.

Duplicate of this bug: 1584049
Summary: Add hardware decoding capabilities on Linux → Add hardware playback capabilities on Linux
Depends on: 1619523
Summary: Add hardware playback capabilities on Linux → [meta] Add hardware playback capabilities on Linux
No longer depends on: 1619523

This is generally a dupe of Bug 1580166 where dmabuf for X11 is implemented.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1580166
You need to log in before you can comment on or make changes to this bug.