Last Comment Bug 740358 - The Chat tab should reopen itself automatically only for messages directed to the user
: The Chat tab should reopen itself automatically only for messages directed to...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 748358
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 07:58 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-04-24 07:44 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (3.39 KB, patch)
2012-03-29 07:58 PDT, Florian Quèze [:florian] [:flo]
bwinton: review+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-03-29 07:58:28 PDT
Created attachment 610548 [details] [diff] [review]
Patch

Currently any received messages (even a left/join message in a chat room) reopens the Chat tab if the user has closed it. This is annoying.
Comment 1 David Ascher (:davida) 2012-03-29 09:03:04 PDT
Alternatively, not even reopen tabs but indicate that there are things needing attention.  I'm not sure that the expectations around automatic tab openings (which are common in IM clients) would fly well with TB users (for whom, I'm guessing, the tab behaviors are likely expected to be more like Firefox or other non-IM apps -- as they're styled the same, etc.)
Comment 2 Blake Winton (:bwinton) (:☕️) 2012-03-29 10:35:29 PDT
I'm kind of thinking the same thing as David here.  I don't really expect tabs to open in Thunderbird, particularly if I've (just) closed them.

How hard would it be to not open the tab, but do something else instead?  (Label or colour the chat button, perhaps?)
Comment 3 Blake Winton (:bwinton) (:☕️) 2012-03-29 10:36:27 PDT
Comment on attachment 610548 [details] [diff] [review]
Patch

(Clearing out the review until we figure out a better ui…)
Comment 4 Florian Quèze [:florian] [:flo] 2012-03-29 13:12:19 PDT
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #2)

> How hard would it be to not open the tab, but do something else instead?

I think the hard part is finding something that is both non obtrusive and hard to miss (+ that doesn't require any new string).
Opening the tab in the background fulfills these 2 conditions.

We will add soon other notifications for incoming messages, similar to what is done for new emails (sound, popup notification), but we will still need something that stays visible so that users don't miss IMs arrived while they were away from their computer.

> (Label or colour the chat button, perhaps?)

While I like this idea, it doesn't replace opening the tab, as the "Chat" button is optional, and likely to be removed by users who know the Command+shift+C keyboard shortcut to open/focus the Chat tab.
Comment 5 Jb Piacentino 2012-03-30 02:33:10 PDT
One possible idea would be to make the 'Chat' toolbar icon carrying the information that 'something' has happened in chat, i.e a superscripted number of pending messages, an animated blinking status blob (nor sure the TB style can support this, but you get the idea)...
Comment 6 Jb Piacentino 2012-03-30 06:29:44 PDT
(In reply to Jb Piacentino from comment #5)
> One possible idea would be to make the 'Chat' toolbar icon carrying the
> information that 'something' has happened in chat, i.e a superscripted
> number of pending messages, an animated blinking status blob (nor sure the
> TB style can support this, but you get the idea)...
I did not read Florian's answer carefully enough. The customizable toolbar is a valid point. 
However, how about adding a chat icon to the top right (next to the list all tabs drop menu). As an example, this is where Lightning adds Calendar and Tasks shortcut icons. We could have an animated icon here, as described in my previous comment.
Comment 7 Blake Winton (:bwinton) (:☕️) 2012-03-30 06:52:39 PDT
You know, I wonder about that.  It seems to me that if the user has chosen to remove the Chat button, it's more likely that they're not interested in the Chat feature, and so not having the notifications wouldn't be a huge problem for them.

And having both a chat button, _and_ a notifier in the top right seems like overkill to me.

I'm happy if power users want to put the chat button in the right-hand side of the tab area, and use it as a status notifier, though.  That seems like a reasonable compromise.

(I also don't think opening the tab in the background is unobtrusive, since I definitely notice it, and it annoys me.  ;)

Later,
Blake.
Comment 8 Jb Piacentino 2012-03-30 09:05:16 PDT
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #7)
> You know, I wonder about that.  It seems to me that if the user has chosen
> to remove the Chat button, it's more likely that they're not interested in
> the Chat feature, and so not having the notifications wouldn't be a huge
> problem for them.
Good point.
> 
> And having both a chat button, _and_ a notifier in the top right seems like
> overkill to me.
> 
> I'm happy if power users want to put the chat button in the right-hand side
> of the tab area, and use it as a status notifier, though.  That seems like a
> reasonable compromise.
> 
> (I also don't think opening the tab in the background is unobtrusive, since
> I definitely notice it, and it annoys me.  ;)
So what is your recommendation ?
Comment 9 Blake Winton (:bwinton) (:☕️) 2012-03-30 09:09:02 PDT
(In reply to Jb Piacentino from comment #8)
> > I'm happy if power users want to put the chat button in the right-hand side
> > of the tab area, and use it as a status notifier, though.  That seems like a
> > reasonable compromise.
> So what is your recommendation ?

I'm happy with your suggestion of marking the chat button somehow.  Normal users will see it, people who don't care about chat will remove the button and not see it, and advanced users will put it in the tab area and get a nice small notification (which they can click on to open the chat tab).

Later,
Blake.
Comment 10 Florian Quèze [:florian] [:flo] 2012-04-19 05:58:13 PDT
Comment on attachment 610548 [details] [diff] [review]
Patch

Even though it seems we more or less agree that we want to notify the user in a different way, I think we should take this patch before the merge to beta as it significantly reduces the annoyance caused by the current behavior. Requesting review again.
Comment 11 Blake Winton (:bwinton) (:☕️) 2012-04-20 13:10:18 PDT
Given that we're preffing IM off for TB 13 beta, do you still think we should take this patch, or should we try to get a better solution coded up in the next six weeks?

Thanks,
Blake.
Comment 12 Florian Quèze [:florian] [:flo] 2012-04-20 14:33:17 PDT
I'm likely going to focus mostly on integrated search and address book integration during the beginning of the next cycle, so I think taking this before the merge would still benefit users of Tb 14 aurora for a few weeks.
Comment 13 Blake Winton (:bwinton) (:☕️) 2012-04-23 12:34:15 PDT
Comment on attachment 610548 [details] [diff] [review]
Patch

Okay, the code looks good to me.  Let's make this a little better for now, and then hopefully much better later.  :)

r=me.

Thanks,
Blake.
Comment 14 Florian Quèze [:florian] [:flo] 2012-04-24 07:44:08 PDT
http://hg.mozilla.org/comm-central/rev/f93bfa99a731

I filed bug 748358 to handle the suggestion of changing the appearance of the chat button instead of reopening the chat tab automatically.

Note You need to log in before you can comment on or make changes to this bug.