Closed Bug 74050 Opened 19 years ago Closed 10 years ago

Japanese characters are trashed in web page attachment; can't send the attachment.

Categories

(MailNews Core :: Internationalization, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 161156
Future

People

(Reporter: wesleyg, Unassigned)

Details

(Keywords: intl)

Attachments

(1 file)

<summary>
Japanese characters are trashed in web page attachment; can't send the 
attachment.

<repro environment>
build 03-29-06 + Win2000-JA
build 03-29-06 + Mac OS 9.04-JA

Not repro with extended (8bit) characters.

<repro steps>
-open mail
-open a new message
-go to file|attach web page
-enter a URL containing Japanese characters, click OK
-click send

<result>
1. Japanese characters are trashed in the web page attachment name.
2. Confirm dialog appears saying the attachment can't be sent (Japanese 
characters are garbage here as well).
Attached image reference image
wesley, i don't think it is a legitimate operation (at least now) to eneter
native ja chars into url , then it is an expected behavior.
I think this is for domain name only.
Please check Japanese file name and path name do not have this problem.
Keywords: intl
I have a html with Japanese filename at
http://rocknroll/users/ji/publish/seamonkey/日本語.html (nihongo.html)
It has the same problem. 
Attaching a local file doesn't have this problem.
For local files, OS file system charset is used.
I think it is not possible to know the charset of file and path name of the 
server. But we can apply url escape for them.
Would be good to support.  It's certainly a minority, but there are a number of
live Japanese web sites with ascii domain names that have URL paths containing
double-byte characters.
Wesley, could you list some of the sites with no ASCII path names?
There is also an issue of using those URL in HREF. So it's good to keep the list
of actual sites for testing.
I didn't record those Japanese internet sites with URLs containing non-ascii
paths that I used for testing at another company.  Maybe there is someone in the
larger international group here who has seen some of these and remembers the sites.

By the way, does anyone have a list of the top most frequently visited Japanese
web sites?
this should be publish on babel ( among 100 web pages that we used for testing
there should 10 japanese)
Target Milestone: --- → Future
Status: NEW → ASSIGNED
Product: MailNews → Core
Product: Core → MailNews Core
QA Contact: ji → i18n
I can repro on Thunderbird 3.1 (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100405 Lanikai/3.1b2pre).  I change assigned to default because Hotta-san is not active developer.

- Step
1. File - Attach - Web Page
2. enter http://日本語.jp

- Result
I insert corrupt string in attachments

- Expected result
Don't corrupt it.
Assignee: nhottanscp → nobody
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 200150
Invalid bug number
Duplicate of bug: 161156
You need to log in before you can comment on or make changes to this bug.