Closed Bug 161156 Opened 18 years ago Closed 10 years ago

Attached URL with JA chars can't be shown correctly in mail window

Categories

(MailNews Core :: Internationalization, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.1b2

People

(Reporter: jeesun, Assigned: m_kato)

References

Details

(Keywords: intl)

Attachments

(3 files)

URL with JA chars can't be displayed when attached in mail.

Steps:
1. Compose a new mail
2. Go to File|Attache Web Page
3. Enter a JA URL and click OK. (e.g. I used my own file 
ttp://rocknroll/users/jeesun/publish/ひらかな.htm)
4. In the top right corner of the compose window, the attached URL can not be
displayed correctly.

A screenshot will be provided.
Keywords: intl
I don't know whether rocknroll is inabled for i18n data. Jessun, are those
escaped chars that show up? ( i can not see the whole path on the screen
shot..)Thanks.
I don't think the whole escaped chars are showing.
QA Contact: marina → jeesun
Status: NEW → ASSIGNED
When we put any JA URL whether it's existing or not, it should be displayed
correctly in "Attachments" box at the upper right corner of the mail compose window.
For example, if we enter "www.abcd.org/ひらかな.html" in the step 3 above (see
this using Shift_JIS), this URL should be displayed as it is in the
"Attachments" box.
changing qa contact
QA Contact: jeesun → marina
Product: MailNews → Core
Is this bug substantially different than bug 200150?  This is using the 'Attach Web Page' function and that one is using the 'Send Page' from the browser, but the end symptom is the same: the URL doesn't appear correctly in the attachment panel.

As there is at least the beginning of a patch there, this probably should be duped to that one.
Product: Core → MailNews Core
QA Contact: marina → i18n
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 200150
I should not dup of bug 200150.  It is seamonkey bug, not mailnews core.
Assignee: nhottanscp → nobody
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Duplicate of this bug: 74050
Assignee: nobody → m_kato
OS: Windows XP → All
Hardware: x86 → All
Attached patch patch v1Splinter Review
Attachment #437520 - Flags: review?(bugzilla)
Comment on attachment 437520 [details] [diff] [review]
patch v1

>-	attribute string    url;
>+	attribute AUTF8String url;

nit: As you're here, please change the tab to a 2-space indent.

>-  if (PL_strncasestr(scheme, "file:", 5))
>+  if (Substring(scheme, 0, 5).LowerCaseEqualsLiteral("file:"))

Please use StringHead(scheme, 5).Lower....

There's another place in this file with this as well.

>   // To work around a mysterious bug in VC++ 6.
>   const char* cset = (!charset || !*charset) ? "UTF-8" : charset;
>-  rv = utf8Cvt->ConvertURISpecToUTF8(nsDependentCString(scheme),
>-                                     cset, utf8Scheme);

As you're no longer using utf8Cvt, you can remove getting that service from the start of the function and you can then remove the inclusion of nsIUTF8ConverterService.h

r=Standard8 with those comments fixed.
Attachment #437520 - Flags: review?(bugzilla) → review+
landed with comments fix
http://hg.mozilla.org/comm-central/rev/96ad66a27b32
Status: NEW → RESOLVED
Closed: 10 years ago10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b2
Comment on attachment 437520 [details] [diff] [review]
patch v1

Errm, mailnews still requires sr for all its patches:

https://developer.mozilla.org/en/Mailnews_and_Mail_code_review_requirements
Attachment #437520 - Flags: superreview?(neil)
Attachment #437520 - Flags: superreview?(neil) → superreview?(bienvenu)
Comment on attachment 437520 [details] [diff] [review]
patch v1

sr=me, modulo standard8's comments.
Attachment #437520 - Flags: superreview?(bienvenu) → superreview+
You need to log in before you can comment on or make changes to this bug.