Consider disabling the rule view's context menu

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dcamp, Assigned: dcamp)

Tracking

13 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13+ verified)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The rule view's context menu has a couple pretty nasty bugs (bug 736014 and 740603).

If the fixes for those are small and low-risk, we should get them in aurora.  If not, we should unhook the context menu in aurora.
No longer depends on: 736014

Updated

5 years ago
Depends on: 742196

Updated

5 years ago
tracking-firefox13: ? → +
(Assignee)

Comment 1

5 years ago
Created attachment 613351 [details] [diff] [review]
Disable the context menu

The fix for the dependent bugs hasn't landed yet, I think we should disabled this menu in 13.
Assignee: mratcliffe → dcamp
Attachment #613351 - Flags: review?(rcampbell)
Comment on attachment 613351 [details] [diff] [review]
Disable the context menu

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

if you wanted to cut down on patch size, you could just comment out the offending test line in the makefile and not hg remove the actual test file.

Up to you.

Requesting Aurora Approval. This will quickly short-circuit our context menu in Aurora (13) which will prevent the occurrence of some nasty bugs. Risk is low.
Attachment #613351 - Flags: review?(rcampbell)
Attachment #613351 - Flags: review+
Attachment #613351 - Flags: approval-mozilla-aurora?

Comment 3

5 years ago
Comment on attachment 613351 [details] [diff] [review]
Disable the context menu

[Triage Comment]
Approved for Aurora 13 - the patch looks fine as is.
Attachment #613351 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/53b9eca24671
status-firefox13: --- → fixed
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [qa+]
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0

Context menu now disabled. verified in 13 beta4, Windows 7, Mac OS 10.6, Ubuntu 12.04
status-firefox13: fixed → verified
You need to log in before you can comment on or make changes to this bug.