RESOLVED DUPLICATE of bug 724549

Status

mozilla.org Graveyard
Server Operations
RESOLVED DUPLICATE of bug 724549
6 years ago
3 years ago

People

(Reporter: rhelmer, Assigned: jakem)

Tracking

Details

(Reporter)

Description

6 years ago
I don't know where this is actually served from, but the host for https://www-dev.allizom.org/ should have a ./includes/config.inc.php with something like:

$config['pfs_endpoint'] = 'https://plugins.stage.mozilla.com/pfs/';

That URL doesn't seem to be working; I noticed there's an invalid cert at least, can we try making it http:// and seeing if that helps? 

If not, http://pfs2.stage.mozilla.com/ (from the sample config) seems to work...

Also, by "work" I mean https://www-dev.allizom.org/en-US/plugincheck/ loads without errors.
(Assignee)

Updated

6 years ago
Assignee: server-ops → nmaul
(Assignee)

Comment 1

6 years ago
The issue here is the expired SSL cert for plugins.stage.mozilla.com. If you go there first and accept the cert, then https://www-dev.allizom.org/en-US/plugincheck/ works normally.

With that as a temporary workaround, I'm dropping the priority on this to normal.

I'm not sure what we can easily do here to resolve this for good. Typically we would want to rename this site to plugins.allizom.org (for stage) or plugins-dev.allizom.org (for dev). For those we have a working wildcard SSL cert already. Does this seem like a feasible solution? It seems relatively straightforward from an IT perspective, but I have no knowledge of the code that might need changed to make this work...
Severity: critical → normal
(Reporter)

Comment 2

6 years ago
(In reply to Jake Maul [:jakem] from comment #1)
> The issue here is the expired SSL cert for plugins.stage.mozilla.com. If you
> go there first and accept the cert, then
> https://www-dev.allizom.org/en-US/plugincheck/ works normally.
> 
> With that as a temporary workaround, I'm dropping the priority on this to
> normal.
> 
> I'm not sure what we can easily do here to resolve this for good. Typically
> we would want to rename this site to plugins.allizom.org (for stage) or
> plugins-dev.allizom.org (for dev). For those we have a working wildcard SSL
> cert already. Does this seem like a feasible solution? It seems relatively
> straightforward from an IT perspective, but I have no knowledge of the code
> that might need changed to make this work...

I am pretty new to this, cc'ing people who might know?

I agree with dropping the severity, thanks!
(In reply to Robert Helmer [:rhelmer] from comment #2)
> 
> I am pretty new to this, cc'ing people who might know?
> 
> I agree with dropping the severity, thanks!

there is bug 724549. will ping people again for feedback
(Assignee)

Comment 4

6 years ago
Excellent... I think this bug can be safely duped to that one then... as when that happens, this will happen automatically. Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 724549
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.