Closed Bug 740835 Opened 10 years ago Closed 7 years ago

Support the Play To contract in Windows 8 Metro

Categories

(Core Graveyard :: Widget: WinRT, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bbondy, Unassigned)

References

Details

Attachments

(1 file)

'Play To' in Windows 8 will allow us to take audio, videos, and images and stream them to DLNA compatible devices such as a TV.

'Play To' is accessible from the Devices charm.
Attached patch Patch v1.Splinter Review
base code to hook up play to contract. 

TODO:

- Find a way to get current media element from current page (maybe via some meta attribute set on an html page)
- Currently I can't create a MediaElement object with our DX app because it is not XAML.  It throws not the correct thread.  The same code works in a Metro C++/CX app though.
Unassigned myself, there's some basic contract handling code already on elm for this.  But we need to add code to do the streaming.  There's some really easy MSDN samples showing how to do it with a few lines of code, but that's only for XAML apps.  I think it can still be done with some direct media or other COM interfaces though.
Assignee: netzen → nobody
Duplicate of this bug: 801132
transfer widget win32->winrt
Component: Widget: Win32 → Widget: WinRT
OS: Windows 8 Metro → Windows 8.1
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.