Last Comment Bug 740945 - remove unused and un-built nsSVGLeafFrame
: remove unused and un-built nsSVGLeafFrame
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Daniel Holbert [:dholbert]
:
: Jet Villegas (:jet)
Mentors:
Depends on: 696078
Blocks: deadcode
  Show dependency treegraph
 
Reported: 2012-03-30 13:28 PDT by Daniel Holbert [:dholbert]
Modified: 2012-04-01 14:08 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.94 KB, patch)
2012-03-30 13:29 PDT, Daniel Holbert [:dholbert]
longsonr: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-03-30 13:28:04 PDT
Bug 696078 removed the Makefile-line for nsSVGLeafFrame.cpp and removed all uses of it, but the .cpp file itself remains.

Filing this bug on removing it, since it's dead code now.
Comment 1 Daniel Holbert [:dholbert] 2012-03-30 13:29:19 PDT
Created attachment 610993 [details] [diff] [review]
fix

I'm doing a clobber build before requesting review, to be absolutely sure this is dead code.
Comment 2 Robert Longson 2012-03-30 13:31:06 PDT
The patch I submitted was supposed to rename this file...

> diff --git a/layout/svg/base/src/nsSVGLeafFrame.cpp b/layout/svg/base/src/SVGFELeafFrame.cpp
> copy from layout/svg/base/src/nsSVGLeafFrame.cpp
> copy to layout/svg/base/src/SVGFELeafFrame.cpp
Comment 3 Daniel Holbert [:dholbert] 2012-03-30 13:34:08 PDT
Ah -- so it looks like you must've accidentally done "hg cp" instead of "hg mv" -- makes sense.

Thanks for the quick r+! :)
Comment 4 Daniel Holbert [:dholbert] 2012-03-30 13:38:55 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ec2d6134783b
Comment 5 Robert Longson 2012-03-30 13:48:24 PDT
(In reply to Daniel Holbert [:dholbert] from comment #3)
> Ah -- so it looks like you must've accidentally done "hg cp" instead of "hg
> mv" -- makes sense.
> 
> Thanks for the quick r+! :)

I didn't land it  :-)
Comment 6 Robert Longson 2012-03-30 13:53:05 PDT
All's well that ends well. I meant to do a move, shouldn't that have counted ;-)
Comment 7 Daniel Holbert [:dholbert] 2012-03-30 14:23:33 PDT
(In reply to Robert Longson from comment #5)
> I didn't land it  :-)

(right -- but the "copy from" in the posted changeset patch indicates that it was a "hg cp".  If it had been a move, it would have said "rename from" instead of "copy from".)

In any case - very minor issue, & indeed all's well that ends well. :)
Comment 8 Ed Morley [:emorley] 2012-03-31 19:29:34 PDT
https://hg.mozilla.org/mozilla-central/rev/ec2d6134783b

Note You need to log in before you can comment on or make changes to this bug.