Closed Bug 740974 Opened 8 years ago Closed 8 years ago

toolbar currentSet setter needs to return 'val' when returning early

Categories

(Toolkit :: Toolbars and Toolbar Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla14

People

(Reporter: dao, Assigned: vingtetun)

References

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.
Does this actually matter in practice? IIRC the return value of XBL setters is actually ignored.
Well, something needs to be done to fix the JS strict warning at least...
Attached patch PatchSplinter Review
Assignee: nobody → 21
Attachment #612586 - Flags: review?(dao)
Comment on attachment 612586 [details] [diff] [review]
Patch

thanks!
Attachment #612586 - Flags: review?(dao) → review+
Sorry, this push was backed out on inbound because one of the changesets caused a leak:
https://hg.mozilla.org/integration/mozilla-inbound/rev/92cc2053db2f
Target Milestone: mozilla14 → ---
https://hg.mozilla.org/mozilla-central/rev/fe5ba1320d47
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.