Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Loading a page with content-type application/json causes crash [@ nsHTMLDocument::StartDocumentLoad ]

RESOLVED FIXED in mozilla14

Status

()

Core
HTML: Parser
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Simon Kornblith, Assigned: Ms2ger)

Tracking

({crash, testcase})

Trunk
mozilla14
x86
Mac OS X
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 611288 [details]
Test case

When trying to load a resource with content-type application/json directly in the browser (but not via XHR), Nightly crashes. One such crash is

https://crash-stats.mozilla.com/report/index/bp-cc774709-06af-44d5-b653-ddfce2120401

I've attempted to attach a file that will reproduce this to the ticket, but if it doesn't reproduce the issue, I'll post a URL.
(Reporter)

Updated

5 years ago
Attachment #611288 - Attachment is obsolete: true
(Reporter)

Comment 1

5 years ago
That attachment didn't get served as application/json, so try http://www.simonster.com/bug741218.php
(Assignee)

Comment 2

5 years ago
Created attachment 611291 [details] [diff] [review]
Patch v1
Assignee: nobody → Ms2ger
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #611291 - Flags: review?(hsivonen)
Comment on attachment 611291 [details] [diff] [review]
Patch v1

Thanks. (My earlier patch for nsHTMLDocument.cpp was probably in flight while JSON landed in nsContentDLF...)
Attachment #611291 - Flags: review?(hsivonen) → review+
Duplicate of this bug: 741265

Updated

5 years ago
Severity: normal → critical
Crash Signature: [@ nsHTMLDocument::StartDocumentLoad]
Keywords: crash, testcase
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/4df84fc7cbf1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
Is this in the most recently released nightly? I want to check to make sure that this crash https://crash-stats.mozilla.com/report/index/bp-e6673058-4911-45cb-b4ba-1a1172120403 is occurring because I don't yet have the patch, and not because there's a different bug floating around.

Comment 7

5 years ago
(In reply to Brandon Savage [:brandon] from comment #6)
> Is this in the most recently released nightly?
The fix will be in Nightly from April 4th.

Updated

5 years ago
Attachment #611288 - Attachment is obsolete: false
Attachment #611288 - Attachment mime type: application/octet-stream → application/json
You need to log in before you can comment on or make changes to this bug.