Closed Bug 741601 Opened 8 years ago Closed 7 years ago

test pilot thunderbird performance slowdowns

Categories

(Thunderbird :: General, defect, major)

11 Branch
x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: glind, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: [gs][wfm?])

Users are complaining that TestPilot is causing performance problems.

I have not been able to reproduce (and haven't tried hard to).



from #maildev
14:54 <%wsmwk_away> seems like more of a philosophical issue than a money issue.  where is the line where such a "person" becomes 
                    viable?
14:55 -!- irving [irving@B22562D9.AEC9E1D6.DA78B690.IP] has joined #maildev
14:55 <%wsmwk_away> irving: dyk are there any known test pilot perf issues on file?
14:56 -!- jabez [abangadie@moz-B0AADE93.cpe.netcabo.pt] has joined #maildev
14:56 -!- jerrylee [dita@moz-F71F5C52.cpe.netcabo.pt] has quit [Ping timeout]
14:56 < irving> I don't know of any, but I haven't been following closely
14:56 -!- jabez is now known as lev
14:57 <%wsmwk_away> http://forums.mozillazine.org/viewtopic.php?p=11877425#p11877425 claims TP affecting perf
15:00 < gregglind> It's possible.
15:01 < gregglind> I don't know TB enough to diagnose.  
15:01 < gregglind> !summon standard8
15:02 < gregglind> Anyone locally able to reproduce the problem?
Can we figure out whether the performance problems are due to the extension or to the study?

If it's the study, we can stop the bleeding by killfiling the study (just delete the study from the index file (as opposed to moving it to the "maintain" section) and all Test Pilot clients will stop running it.)
From the aforementioned mozillazine link:

When TP is enabled and TB started normally then there will quite quickly be an instance of the problem. The first pause seems to always occur around four or five seconds after launch for a duration of about nine seconds. There will be subsequent pauses but far enough apart to erode my patience to establish whether there is a pattern of consistency in frequency and/or duration.

-VenCain

64-bit Win 7 Pro running native on a new MacBook Pro.
VenCain: With Test Pilot enabled, if you go to Tools -> Test Pilot -> All Your User Studies, are there any active studies listed?

Roughly how far apart are the subsequent pauses? (seconds, minutes, hours, variable?)

Also can you look in your profile folder and check the size of the TestPilotErrorLog.log file? (see https://support.mozillamessaging.com/en-US/kb/profiles for how to locate your profile folder).

If you can also shutdown Thunderbird, move that file elsewhere and then restart, and see if the hangs still occur that would be useful.

If you're still getting hangs can you send me a copy of the new file that's being created.

(Side note, I don't think we should be creating that file by default, and I will be filing a bug on that, but I'd also like to eliminate it as a possible cause of slow down first).
A Week in the Life is scheduled to end on 3 Apr.

The pauses are at least minutes apart but I've not sat down and measured it.  I started drafting a mail and held down a key for a couple of minutes without seeing it reappear during that time...

04/03/2012  16:32         1,859,756 TestPilotErrorLog.log

Since it always pauses when starting up I correlated that with the contents of the TestPilotErrorLog.log file.  It seems to match with the following:

2012-04-03 16:38:53	TestPilot.RemoteCode INFO	Adding memory observer.
2012-04-03 16:39:00	TestPilot.Setup      INFO	Loaded task week_life.js

I next removed that file but it did not eliminate the problem so I e-mailed you the newly produced file.

Thanks,

-VenCain
(tentatively) I might also be seeing this on my laptop - compose pane
This won't be a problem in version 12, correct?
Keywords: perf
(In reply to Wayne Mery (:wsmwk) from comment #7)
> (tentatively) I might also be seeing this on my laptop - compose pane

This would be global to Thunderbird not just one window.

(In reply to Wayne Mery (:wsmwk) from comment #8)
> This won't be a problem in version 12, correct?

Test pilot runs on multiple versions of Thunderbird. If the issue is with the test itself or with test pilot itself then it will probably affect more than one version.
(In reply to Wayne Mery (:wsmwk) from comment #6)
> https://getsatisfaction.com/mozilla_messaging/topics/
> periodic_not_responding_message_lockup

this got merged to https://getsatisfaction.com/mozilla_messaging/topics/stability_and_speed_issues_with_ver_11 which has (only) ~3 reporters.


(In reply to Mark Banner (:standard8) from comment #9)
> (In reply to Wayne Mery (:wsmwk) from comment #7)
> > (tentatively) I might also be seeing this on my laptop - compose pane
> 
> This would be global to Thunderbird not just one window.

Noted - it seems to me compose is somewhat more needy of resources compared to most other windows
What is reasonable next step?
Do we believe this happens only with "old" versions of test pilot?
See Also: → 710056
I re-enabled test pilot (now TB 12.0.1/TP 1.3.9) and the initial, fairly immediate instance is gone.

I'll leave it on and report back if I see it again.  Lack of me posting further means it no longer occurs on my unit.

-VenCain
(In reply to VenCain from comment #12)
> I re-enabled test pilot (now TB 12.0.1/TP 1.3.9) and the initial, fairly
> immediate instance is gone.
> 
> I'll leave it on and report back if I see it again.  Lack of me posting
> further means it no longer occurs on my unit.
> 
> -VenCain

VenCain, thanks for that info. are you still running clean?
(just to be clear, your original report in mozillazine was TB11 with Google Docs Viewer 1.8, Lightning 1.3 and Test Pilot 1.3.8.)


For the record I find no other bug reports on this issue and I count only two forum reports:
- https://getsatisfaction.com/mozilla_messaging/topics/stability_and_speed_issues_with_ver_11#reply_8625098
- http://forums.mozillazine.org/viewtopic.php?p=11879471#p11879471
I closed https://getsatisfaction.com/mozilla_messaging/topics/stability_and_speed_issues_with_ver_11 because Fred and Karl have not responded 

(In reply to VenCain from comment #12)
> I'll leave it on and report back if I see it again.  Lack of me posting
> further means it no longer occurs on my unit.
> 
> -VenCain

WFM?
Whiteboard: [gs] → [gs][wfm?]
dont' we have another bug report mentioning test pilot and we determined the cause is something else?
Flags: needinfo?
I'm not sure we ever conclusively proved issues relating to just test pilot itself.
Assignee: mbanner → nobody
Flags: needinfo?
yeah. and I searched and found nothing new in the last 6 months.
i think we can call this WFM (or invalid)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.