recreate releng-mirror01 in scl3, with more disk space

RESOLVED FIXED

Status

Infrastructure & Operations
Virtualization
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: bhearsum, Assigned: Aj)

Tracking

Details

(Reporter)

Description

6 years ago
The rsync module that this machine tracks has grown a lot since it was first set-up, and it's impossible to keep it to a size that machine can handle. Can we recreate this VM with at least 300GB of disk space?
(Reporter)

Comment 1

6 years ago
I should probably get the colo name right.
Summary: recreate releng-mirror01 in scl1, with more disk space → recreate releng-mirror01 in scl3, with more disk space
Can you please create a vm called releng-mirror01.srv.releng.scl3.mozilla.com in vlan248 with the following specs:

1G RAM
1 CPU
500G disk (because this is only going to grow larger as proven by our outgrowing the first one)
centos 6.2
Assignee: server-ops-releng → server-ops
Component: Server Operations: RelEng → Server Operations: Virtualization
QA Contact: arich → dparsons

Updated

6 years ago
Assignee: server-ops → dparsons
Status: NEW → ASSIGNED
All done, needs to be puppetized.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
OK, I misread the bug, this needs to be CentOS 6.2.

:aj, can you take this over and rebuild it as CentOS 6.2?
Assignee: dparsons → afernandez
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

6 years ago
Status: REOPENED → ASSIGNED
(In reply to Dan Parsons [:lerxst] from comment #4)
> OK, I misread the bug, this needs to be CentOS 6.2.
> 
> :aj, can you take this over and rebuild it as CentOS 6.2?

ping?
This is in the queue of VMs being moved / created, and is more complicated due to the OS requirement.  Aj will get to it when he can.
(Reporter)

Comment 7

6 years ago
Personally, I'm not fussy about the OS other than it being CentOS. I'm also happy to wait for whatever version RelOps thinks is best.
It's the not-RHEL part that makes it tricky (although only a little bit).
Blocks: 729667
No longer blocks: 646076
I gave AJ the same kickstart profile that was used to create the centos 6.2 template for kvm in scl1.
(Reporter)

Comment 10

6 years ago
I think this dep got removed by mistake.
Blocks: 646076
Blocks: 740144
(Assignee)

Comment 11

6 years ago
The Centos 6.2 release files are being downloaded.
Once done, VM template will be kickstarted.
No longer blocks: 646076, 740144
(Assignee)

Comment 12

6 years ago
Template is being created (CentOS 6.2 being installed)
(Assignee)

Comment 13

6 years ago
kickstart file provided was not using LVM, LVM is wanted.
Redoing template.
(In reply to Adrian Fernandez [:Aj] from comment #11)
> The Centos 6.2 release files are being downloaded.
> Once done, VM template will be kickstarted.

per irc w/Aj, these bug dependencies were removed unintentionally. Replacing as requested.
Depends on: 646076, 740144
(In reply to John O'Duinn [:joduinn] from comment #14)
> (In reply to Adrian Fernandez [:Aj] from comment #11)
> > The Centos 6.2 release files are being downloaded.
> > Once done, VM template will be kickstarted.
> 
> per irc w/Aj, these bug dependencies were removed unintentionally. Replacing
> as requested.

DUH! and then I put the bug#s in the wrong field. Bug#646076, bug#740144 are blocked on bug#741774... not the other way around. 

(sorry for bugspam)
Blocks: 646076, 740144
No longer depends on: 646076, 740144
(Assignee)

Comment 16

6 years ago
releng-mirror01.srv.releng.scl3 is online.

Please verify that all is well with the server so that the template could be used on other deployments.
(Reporter)

Comment 17

6 years ago
It looks OK at a glance. I'll know more after I puppetize it. Thanks!
(Reporter)

Updated

6 years ago
Blocks: 744803
(Assignee)

Comment 18

6 years ago
Confirmed with Ben on irc, that all looks well.

Closing bug, feel free to re-open if anything is wrong with base template.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
No longer blocks: 740144
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.