Last Comment Bug 742274 - B2G: Hardware buttons do not work on akami.
: B2G: Hardware buttons do not work on akami.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 06:23 PDT by José Antonio Olivera Ortega [:jaoo]
Modified: 2012-04-19 16:57 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to retry failed PDP context activation (4.82 KB, patch)
2012-04-16 05:50 PDT, Fernando R. Sela (no CC, needinfo please) [:frsela]
no flags Details | Diff | Splinter Review

Description José Antonio Olivera Ortega [:jaoo] 2012-04-04 06:23:56 PDT
Hardware buttons do not work on akami I guess due new ICS based input reader. This story comes from [1] and Bug 741038. 

[1] https://github.com/andreasgal/B2G/issues/254
Comment 1 Fernando R. Sela (no CC, needinfo please) [:frsela] 2012-04-16 05:50:52 PDT
Created attachment 615311 [details] [diff] [review]
Patch to retry failed PDP context activation

This patch enables reconnection process when the PDP context creation failed (due to a APN URL error, no coverage, ...)

This one, has a "simple" retry policy. First time: 10 secs, Next 30, next 120, ...

It's required to patch over the 717122 last patches.

Also, I added a callback notification on ril_worker since in 727319 this had been removed. Note that this callback only works on Data Connection failures.
Comment 2 Fernando R. Sela (no CC, needinfo please) [:frsela] 2012-04-16 05:52:09 PDT
Excuse me, I failed the bug number, please remove it.
Comment 3 José Antonio Olivera Ortega [:jaoo] 2012-04-19 16:57:46 PDT
Fixed (see [1]) by cjones. 

[1] https://github.com/andreasgal/B2G/commit/6842d90be8e92b98ce5fc436913532ff88c7b500

Note You need to log in before you can comment on or make changes to this bug.