Last Comment Bug 742644 - IRC's username empty text ("and server") in the Chat Account Wizard is confusing
: IRC's username empty text ("and server") in the Chat Account Wizard is confusing
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: 13 Branch
: x86_64 Linux
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Florian Quèze [:florian] [:flo]
:
:
Mentors:
Depends on:
Blocks: 740280
  Show dependency treegraph
 
Reported: 2012-04-05 00:25 PDT by Kami
Modified: 2012-05-15 03:19 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (45.02 KB, image/png)
2012-04-05 03:16 PDT, Florian Quèze [:florian] [:flo]
no flags Details
Patch (1.37 KB, patch)
2012-05-09 08:44 PDT, Florian Quèze [:florian] [:flo]
clokep: review+
florian: ui‑review+
Details | Diff | Splinter Review

Description Kami 2012-04-05 00:25:09 PDT
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20120327 Firefox/13.0a2
Build ID: 20120327115436

Steps to reproduce:

Creating IRC connect, I am on username page


Actual results:

When I selected Server textfield while Username is empty, Username field shows grey "and server" text.


Expected results:

Probably we should no do anything or write "Enter username here" or something similar.
Comment 1 Florian Quèze [:florian] [:flo] 2012-04-05 03:16:37 PDT
Created attachment 612487 [details]
Screenshot
Comment 2 Florian Quèze [:florian] [:flo] 2012-04-05 03:26:12 PDT
This is because the text used for the username empty text is the same as the text used for what's in parentheses after "username" in the sentence above.
Blake, should we just remove that "and server" text completely for IRC accounts?
Comment 3 Patrick Cloke [:clokep] 2012-05-09 07:34:45 PDT
(In reply to Florian Quèze from comment #2)
> Blake, should we just remove that "and server" text completely for IRC
> accounts?
Please do, it doesn't make any sense. If we'd like to set the empty text, we should use a different string.
Comment 4 Florian Quèze [:florian] [:flo] 2012-05-09 08:44:02 PDT
Created attachment 622381 [details] [diff] [review]
Patch

Let's revert this change (https://hg.instantbird.org/instantbird/rev/e142bb7beb1a) that we added during the ui-review of IM-in-Tb's main patch but turns out to be even more confusing than what it was trying to improve.

ui-r=bwinton over Vidyo

Note: We started discussing a better long term solution at https://bugzilla.instantbird.org/show_bug.cgi?id=1426#c6
Comment 5 Patrick Cloke [:clokep] 2012-05-09 08:47:13 PDT
Comment on attachment 622381 [details] [diff] [review]
Patch

This looks fine; I definitely think it's less confusing without this.

(Uhh...I'm noticing now it also refers to GTalk? Poor review last time I guess. :()
Comment 6 Florian Quèze [:florian] [:flo] 2012-05-15 03:19:02 PDT
http://hg.mozilla.org/comm-central/rev/cf8f349b1fe6

Note You need to log in before you can comment on or make changes to this bug.