Empty bookmarks toolbar on startup due to All-in-one sidebar add-on

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: javad, Unassigned)

Tracking

12 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120321033733

Steps to reproduce:

hidden bookmarks? when opening firefox, the booksmarks are not visible, only empry space


Actual results:

hidden bookmarks? when opening firefox, the booksmarks are not visible, only empry space, 
if i go to view >  toolbar > Unlclick ookmark toolbar and than click it again it shows up!!
i need to do everytime i start FF, it has started aftre last update


Expected results:

it should be directly visible
Hi, may you please try safe mode? http://support.mozilla.org/kb/safe+mode
(Reporter)

Comment 2

6 years ago
try safe mode and do what??
tried resetting toolbar options and started, but problem remains.

do i need to do something else aftre strarting in safe mode- as such safe mode has no bookmarks toolbar!!
no, safe mode is just to understand if an add-on may be the cause of your problem.

We are aware some user is suffering this issue, but we can't reproduce and you are the first one reporting it to bugzilla, so there's some debugging to do.

Could you please check if disabling plug-ins (like Realplayer, Quicktime, and so on...) in about:addons solves the problem?

Updated

6 years ago
Summary: bookmarks toolbar → Empty bookmarks toolbar on statup

Updated

6 years ago
Summary: Empty bookmarks toolbar on statup → Empty bookmarks toolbar on startup
(Reporter)

Comment 4

6 years ago
tried dis-abling all, all the plug-ins- do not help, problem persists.
Duplicate of this bug: 723034
You said you resetted toolbar customizations already, so you have the bookmarks toolbar at its usual place?
Is the Error Console reporting any error when the toolbar is empty?
(Reporter)

Comment 7

6 years ago
resetted toolbar customisation? i said clicking and unclicking the option from view > toolbar menu, and i presume resetting could be a wrong word? though not sure.

als, error console? not sure where i check it, or see it? please advise

Comment 8

6 years ago
Talked to javad over email. Looks like there's weirdness in his localstore.rdf

His bookmarks toolbar line:

  <RDF:Description RDF:about="chrome://browser/content/browser.xul#PersonalToolbar"
                   collapsed="false" />

Where it should read (thanks Mossop):

  <RDF:Description RDF:about="chrome://browser/content/browser.xul#PersonalToolbar"
                   mode="icons"
                   currentset="personal-bookmarks"
                   iconsize="small"
                   collapsed="false" />

We're going to try deleting the file and seeing if that helps.  There are also a lot of enabled extensions, one of which may have caused the breakage in the first place:

ĀµTorrent Status 
Add-on Compatibility Reporter 
Alexa Sparky 
All-in-One Sidebar 
Autofill Forms 
Better Gmail 2 
Bit.uZ plugin 
BitTorrent WebUI 
BugMeNot 
Classic Compact Options 
ColorfulTabs 
Download Manager Tweak 
Download Statusbar 
DownloadHelper 
DownThemAll! 
EmailTheWeb.com 
FEBE 
Firebug 
FireFTP 
Flagfox 
Flashblock 
FlashGot 
Full Map 
Google Shortcuts 
Google Toolbar for Firefox 
India Rail Info Firefox App 
LastPass 
Lazarus: Form Recovery 
Microsoft .NET Framework Assistant 
MR Tech Toolkit 
Multirow Bookmarks Toolbar 
NoScript 
QuickNote 
ScrapBook 
Sun Cult 
Sxipper 
Test Pilot 
Undo Closed Tabs Button 
Update Notifier 
WiseStamp 
Xmarks 
Yoono

And disabled extensions:

AVG Safe Search 
BabelFish 
ColorZilla 
CoolPreviews 
eType Toolbar 
Evernote Web Clipper 
Fast Search by Surf Canyon 
FastestFox 
Gist 
Greasemonkey 
ImTranslator 
Java Console 
Java Quick Starter 
Rapidlibrary Search ToolBar 
ROSEVOL 
SkipScreen 
Split Browser 
TinEye Reverse Image Search 
TV-Fox 
Update Scanner 
Yahoo! Toolbar

Comment 9

6 years ago
Not entirely sure what happened, but he reports that just disabling the All-in-one sidebar extension and restarting seems to make it work now. I'm not sure if localstore.rdf was fixed by doing that or if there were other steps in this process that fixed it.

Comment 10

6 years ago
QA has confirmed that using all-in-one sidebar in Firefox 12 causes the behavior.

Updated

6 years ago
Duplicate of this bug: 742095
(Reporter)

Comment 12

6 years ago
cheng- special thnaks and apprecaition of all involved!
Many thanks for figuring this out, quite strange, I wonder if it's something changed in the add-on or in the product (that the add-on was not expecting).

(In reply to [:Cww] from comment #10)
> QA has confirmed that using all-in-one sidebar in Firefox 12 causes the
> behavior.

So, did someone contact the All-in-one Sidebar author already?

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Empty bookmarks toolbar on startup → Empty bookmarks toolbar on startup due to All-in-one sidebar add-on

Updated

6 years ago
Component: Untriaged → Extension Compatibility
QA Contact: untriaged → extension.compatibility
Adding All-in-One Sidebar dev to CC list.

Comment 15

6 years ago
Many thanks for reporting, figuring out and adding to the list.

I can confirm that All-in-One Sidebar causes this issue. I re-used some code from the Firefox source to build the toolbar funcionality. The source has been changed and I have to update AiOS. I already work for an update and hope that it's ready to release very soon.

Comment 16

6 years ago
The bug has been fixed and the new version 0.7.15 has been fully reviewed and released:
https://addons.mozilla.org/firefox/addon/all-in-one-sidebar/

You can close this bug. :)
Thanks for reporting back.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.