PNG rendering ( text anti-alias edges use case ) looks bad

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: mgalli, Unassigned)

Tracking

11 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-10-11 WFM])

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 612567 [details]
cartao.png open with Firefox 10 and Firefox 11 and see the text closer

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Opened a PNG image with Firefox 10 and Firefox 11


Actual results:

Firefox 11 showed the edges of the text with a poor rendering


Expected results:

Fine rendering.
(Reporter)

Comment 1

6 years ago
Created attachment 612568 [details]
Comparisons with desktop screencapture ( good antialias is Firefox 10 )

Comment 2

6 years ago
Really, there is a difference.
I've compared it using Fx 10 and 11 on Windows 7 64-bits.

Comment 3

6 years ago
Created attachment 612574 [details]
Comparison between Firefox 10 and 11 using Windows Seven 64 bits.
(Reporter)

Updated

6 years ago
Component: General → Graphics
Created attachment 612651 [details]
Comparison between Firefox 10 and 11 using Ubuntu Linux 11.10 64 bits.
The difference is happening on Linux Firefox for Linux too!
The difference is happening on Firefox for Linux too!
(Reporter)

Updated

6 years ago
Blocks: 760442

Comment 7

6 years ago
This is another problem caused by bug 376997.

The letters have some transparent pixels around the edges, which means the background colour shows through. Starting in Firefox 11, images are shown against a dark background instead of a white background, which means the edge pixels are dark instead of white. That's what's causing the problem.

Comment 8

6 years ago
Created attachment 629538 [details]
red background

This shows how it appears when viewed against a red background. You can see which pixels are affected by the background colour.

Comment 9

6 years ago
The best way to fix it would be to just remove the transparency from the image.

Comment 10

5 years ago
I think this issue is fixed, at least on Firefox Beta and Nightly, Windows 7 and HWA doesn't make a difference.

Comment 11

5 years ago
(In reply to Guilherme Lima from comment #10)
> I think this issue is fixed, at least on Firefox Beta and Nightly, Windows 7
> and HWA doesn't make a difference.

do you agree?
Flags: needinfo?(mjh563)
Flags: needinfo?(mgalli)
Whiteboard: [closeme 2013-10-11 WFM]

Comment 12

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #11)
> (In reply to Guilherme Lima from comment #10)
> > I think this issue is fixed, at least on Firefox Beta and Nightly, Windows 7
> > and HWA doesn't make a difference.
> 
> do you agree?

Yes, I guess this got fixed in Firefox 15 by bug 754133.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mjh563)
Resolution: --- → WORKSFORME

Updated

2 years ago
Flags: needinfo?(mgalli)
You need to log in before you can comment on or make changes to this bug.