Last Comment Bug 754133 - Set background of standalone images (the image itself, not the whole page) to white
: Set background of standalone images (the image itself, not the whole page) to...
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Themes (show other bugs)
: 11 Branch
: All All
: -- normal with 4 votes (vote)
: mozilla15
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
: Dão Gottwald [:dao]
Mentors:
http://www.cdc.gov/nchs/data/databrie...
: 728085 alpha_png_background (view as bug list)
Depends on: 756419
Blocks: 754539 376997 783874 1089880
  Show dependency treegraph
 
Reported: 2012-05-10 17:35 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2014-10-27 14:55 PDT (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug (10.89 KB, patch)
2012-05-10 18:05 PDT, Jared Wein [:jaws] (please needinfo? me)
bzbarsky: review+
Details | Diff | Splinter Review
Patch for bug v2 (11.73 KB, patch)
2012-05-14 15:39 PDT, Jared Wein [:jaws] (please needinfo? me)
bzbarsky: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2012-05-10 17:35:16 PDT
See discussion in mozilla.dev.apps.firefox earlier today.
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2012-05-10 18:05:27 PDT
Created attachment 622999 [details] [diff] [review]
Patch for bug
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2012-05-10 18:11:11 PDT
Comment on attachment 622999 [details] [diff] [review]
Patch for bug

r=me
Comment 3 Mark Goodhand 2012-05-11 00:15:37 PDT
(In reply to Boris Zbarsky (:bz) from comment #0)
> See discussion in mozilla.dev.apps.firefox earlier today.

Here, I'm guessing:

http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/827a52f71d092748

Glad to see some action on this.
Comment 4 Alfred Kayser 2012-05-11 01:19:16 PDT
Use to get a patterned background like in image editors (PSD, Paint.net, etc):
background:-moz-Dialog url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQAQMAAAAlPW0iAAAABlBMVEWgoKClpaUrSK7yAAAAAnRSTlNkFG3Yt+YAAAAPSURBVHheY2D4jxXhEgYAfr8P8SM7T18AAAAASUVORK5CYII=);
Comment 5 Dão Gottwald [:dao] 2012-05-11 01:57:10 PDT
(In reply to Alfred Kayser from comment #4)
> Use to get a patterned background like in image editors

Please file a separate bug on this. (I think we might actually want to try this, depending on how this bug will be received.)
Comment 6 Frank Lion 2012-05-11 05:56:35 PDT
In case this is useful to Boris, here are my reasonings on this one from a previous bug - https://bugzilla.mozilla.org/show_bug.cgi?id=713555#c24

Good luck. :)
Comment 7 Virtual_ManPL [:Virtual] - (ni? me) 2012-05-11 09:08:58 PDT
Just hope this bug won't be hijacked and closed like bug #713555, hhich have the only good concept with dealing with transparent images, compared to using black or black background.
Comment 8 Mozilla RelEng Bot 2012-05-11 16:09:29 PDT
Autoland Patchset:
	Patches: 622999
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=93291ada1202
Try run started, revision 93291ada1202. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=93291ada1202
Comment 9 Jared Wein [:jaws] (please needinfo? me) 2012-05-12 15:54:33 PDT
This test is failing on Windows in the try push:
> REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/image/test/reftest/icon/win/bug415761.sjs | image comparison (==)
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2012-05-14 15:39:55 PDT
Created attachment 623851 [details] [diff] [review]
Patch for bug v2

This patch changes bug415761.sjs to explicitly set the icon dimensions.

On the other hand, I think that this test is actually quite broken, and writing this patch revealed the broken-ness. The test previously passed because we were testing a white background against a white background. It then passed because we were testing a dark grey background against a dark grey background. It only started failing now because we started explicitly setting a background-color for the image.
Comment 11 Mozilla RelEng Bot 2012-05-14 15:42:03 PDT
Autoland Patchset:
	Patches: 623851
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=6699388d2f96
Try run started, revision 6699388d2f96. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=6699388d2f96
Comment 12 Boris Zbarsky [:bz] (still a bit busy) 2012-05-14 18:21:06 PDT
Comment on attachment 623851 [details] [diff] [review]
Patch for bug v2

r=me
Comment 13 Jared Wein [:jaws] (please needinfo? me) 2012-05-15 10:54:09 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/836e451c8b77
Comment 14 Ed Morley [:emorley] 2012-05-16 03:42:09 PDT
https://hg.mozilla.org/mozilla-central/rev/836e451c8b77
Comment 15 Terrell Kelley 2012-05-23 20:03:03 PDT
*** Bug 743474 has been marked as a duplicate of this bug. ***
Comment 16 bogas04 2012-05-25 03:03:36 PDT
A mockup was posted by Stephen to deal with specific images requiring white background etc

https://people.mozilla.com/~shorlander/files/stand-alone-image/stand-alone-image-01.html

Is it in plans ?
Comment 17 KLB 2013-10-18 16:38:59 PDT
*** Bug 728085 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.