Closed Bug 743227 Opened 8 years ago Closed 8 years ago

"Always show" does not display the popoups until a page reload

Categories

(Firefox for Android :: General, defect)

14 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 14
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: AdrianT, Assigned: Margaret)

References

Details

Attachments

(2 files, 1 obsolete file)

Fennec/14.0a1 2012-04-06
Device: Motorola Droid 2(Android 2.3)

Steps to reproduce:
1. Load http://www.popuptest.com/popuptest1.html.
2. When asked choose show and wait for the popups to trigger.
3. Close all popups and reload the page.
4. Choose "Always Show".

Expected results:
The popups are triggered.

Actual results:
The popups are triggered only after a page reload.
Assignee: nobody → margaret.leibovic
blocking-fennec1.0: --- → ?
This looks like it probably never worked...

http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#3515

This is easy to fix.

I also found that desktop Firefox doesn't immediately show popups when you select "Allow", but the UI is different there (you can see a list of popup windows you might want to open), so I don't think we need to be consistent here.
Attached patch patch (obsolete) — Splinter Review
Attachment #612914 - Flags: review?(mbrubeck)
Comment on attachment 612914 [details] [diff] [review]
patch

Nice!  Now could you also fix the same bug in desktop Firefox (bug 731865)? :)
Attachment #612914 - Flags: review?(mbrubeck) → review+
Attached patch patchSplinter Review
I actually just found that we need to set the permission before opening the other popups, since they can come to the foreground, and allowPopupsForSite uses BrowserApp.selectedBrowser.currentURI to set the permission.
Attachment #612914 - Attachment is obsolete: true
Attachment #612915 - Flags: review?(mbrubeck)
Attachment #612915 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/90c1118bce0a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Blocks: 737082
Verified fixed on: 
Nightly Fennec 14.0a2 (2012-04-29)
Nightly Fennec 15.0a1 (2012-04-29)
Device: HTC Desire Z
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
blocking-fennec1.0: ? → +
You need to log in before you can comment on or make changes to this bug.