icedove-10.0.3 build fails "Makefile:45: ../../..//config/autoconf.mk: No such file or directory"

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: andre.paulista, Unassigned)

Tracking

10 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [esr])

Attachments

(8 attachments)

(Reporter)

Description

7 years ago
Created attachment 612946 [details]
PKGBUILD

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20120320 Iceweasel/11.0
Build ID: 20120320180655

Steps to reproduce:

i'm creating a icedove package for Parabola distro https://wiki.parabolagnulinux.org (derivate from ArchLinux) 


Actual results:

i had problems to build with gcc-4.7.0 and I adding patches that solved the issues based from comments of this report http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667205
But after, i found a error that i can't to resolve "Makefile:45: ../../..//config/autoconf.mk: No such file or directory"


Expected results:

mozconfig and PKGBUILD files configured incorrectly or is necessary to add more patches to complete building
(Reporter)

Comment 1

7 years ago
Created attachment 612947 [details]
mozconfig
(Reporter)

Comment 2

7 years ago
Created attachment 612948 [details] [diff] [review]
gcc47.patch
(Reporter)

Comment 3

7 years ago
Created attachment 612949 [details]
channel-prefs.js
(Reporter)

Comment 4

7 years ago
Created attachment 612950 [details]
vendor.js
(Reporter)

Comment 5

7 years ago
Created attachment 612956 [details]
icedove-libre-10.0.3-1-x86_64-build.log
(Reporter)

Comment 6

7 years ago
Created attachment 612957 [details]
config.log
(Reporter)

Comment 7

7 years ago
Created attachment 612958 [details]
icedove-libre-10.0.3-1-x86_64-package.log
(Reporter)

Updated

7 years ago
Severity: normal → critical
Priority: -- → P4

Comment 8

6 years ago
Is this a bug report or rather a support request? Not quite clear to me. Note that Icedove is a 3rd-party build, so technically I don't think it's covered here.

If you don't get a response here, you can also try the MZ 3rd-party build forum at http://forums.mozillazine.org/viewforum.php?f=42 to obtain some feedback.
Priority: P4 → --
Whiteboard: [esr]
Version: 3.0 → 10
So, the relevant log is:
make[4]: Entering directory `/build/src/mozilla-build/moz-objdir/debian/icedove-branding'
Makefile:45: ../../..//config/autoconf.mk: No such file or directory
../../..//config/config.mk:57: ../../../config/autoconf.mk: No such file or directory

Apparently, DEPTH is wrong in debian/icedove-branding/Makefile.in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 10

6 years ago
Maybe report this at http://www.debian.org/Bugs/ as it's apparently a Debian-specific issue.
(Reporter)

Comment 11

6 years ago
(In reply to Mike Hommey [:glandium] from comment #9)
> So, the relevant log is:
> make[4]: Entering directory
> `/build/src/mozilla-build/moz-objdir/debian/icedove-branding'
> Makefile:45: ../../..//config/autoconf.mk: No such file or directory
> ../../..//config/config.mk:57: ../../../config/autoconf.mk: No such file or
> directory
> 
> Apparently, DEPTH is wrong in debian/icedove-branding/Makefile.in.

ok, i will add patch in Makefile.in to fix the issue, and will build it again.
(Reporter)

Comment 12

6 years ago
(In reply to rsx11m from comment #10)
> Maybe report this at http://www.debian.org/Bugs/ as it's apparently a
> Debian-specific issue.

I think that Debian Bugs is just for Debian distro because they using a program to report their bugs, although that the source code is from Debian, I want to do a Thunderbird program with icedove branding port to the Parabola distro
You need to log in before you can comment on or make changes to this bug.