Touch events are broken in XUL Fennec

VERIFIED FIXED in Firefox 15

Status

Fennec Graveyard
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: wesj, Assigned: mbrubeck)

Tracking

({regression})

Firefox 13
Firefox 15
All
Android
regression
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Reported from Kairo in IRC that touch events (even single touch ones) are broken in XUL Fennec. We need some testing to verify.

We're unlikely to ship another release build of XUL Fennec. We may end up pushing this to the Beta channel if Native slips again (although no one has tested Aurora yet to know if it has this problem).
(Reporter)

Comment 1

5 years ago
Adding Kairo. I don't think this will be a priority for the team, but want to track the regression. Metro Firefox should also be seeing this (although they'll eventually want to turn off this silly Parent Process MouseEvents->Child process touch events trickery we did.
(Assignee)

Comment 2

5 years ago
The tests at http://limpet.net/w3/touchevents/single-touch.html fail with exception "Permission denied for <http://limpet.net> to create wrapper for object of class UnnamedClass."
Keywords: regression, regressionwindow-wanted
Version: Trunk → Firefox 14

Comment 3

5 years ago
Also add romaxa, who is doing the N9 builds, that are XUL as well and show that bug as well (I only tried Nightly versions there).

Comment 4

5 years ago
OK, I did some regression testing, the bug was introduced between the 2012-03-12 and 2012-03-13 13.0a1 mozilla-central builds. This means that Aurora is affected.

FYI, sites to use for testing are http://lantea.kairo.at/ (panning the map - which is what I used for regression testing), http://mandelbrot.kairo.at/ (zooming into the set via dragging over a rendered image), http://browserquest.mozilla.org/ (moving the character via tapping on the playing field). Of course, all those are single-touch events, as XUL Fennec doesn't support multitouch.

Here's more info on the regression range:

Last good build:
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2012-03-12-03-11-36-mozilla-central-android-xul/
20120312031136
http://hg.mozilla.org/mozilla-central/rev/5ec9524de1af

First bad build:
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2012-03-13-03-11-12-mozilla-central-android-xul/
20120313031112
http://hg.mozilla.org/mozilla-central/rev/1ca7a94573f2

Checkin range:
hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5ec9524de1af&tochange=1ca7a94573f2


I searched for "touch" in the pushlog and found this one:
http://hg.mozilla.org/mozilla-central/rev/554ab0a2f470
Peter Van der Beken — Fix for bug 734503 (Add new DOM binding for TouchList). r=jst.

Could that be what triggers this bug?
status-firefox13: --- → affected
status-firefox14: --- → affected
Keywords: regressionwindow-wanted
(Reporter)

Comment 5

5 years ago
Looks likely to me.
Can someone try setting the dom.new_bindings pref to false and check if that fixes it?

Comment 7

5 years ago
(In reply to Peter Van der Beken [:peterv] from comment #6)
> Can someone try setting the dom.new_bindings pref to false and check if that
> fixes it?

Unfortunately, that doesn't change anything. :(
yep, with disabled new dom bindings nothing has changed

Updated

5 years ago
Blocks: 745071

Comment 9

5 years ago
Has anyone tried backing out bug 734503 to see if it fixes the issue?

Comment 10

5 years ago
(In reply to Jim Mathies [:jimm] from comment #9)
> Has anyone tried backing out bug 734503 to see if it fixes the issue?

I don't do my own builds, but if you get around to doing a try build with it backed out, I can test that.
(In reply to Jim Mathies [:jimm] from comment #9)
> Has anyone tried backing out bug 734503 to see if it fixes the issue?

Tested with that patch backed out, and single touch events works ok,
Sand-trap gape is usable without that patch.
(Assignee)

Comment 12

5 years ago
Requesting tracking-firefox13 because this is a regression in XUL Fennec 13 that breaks web content, including popular sites like Google Maps.  (We aren't shipping XUL Fennec 13 to the release channel, but we should fix this before it reaches beta.)

Peter, would it be reasonable to back out bug 734503 on Aurora until a better fix is found?  Would the backout have any risks or side effects?
Blocks: 734503
tracking-firefox13: --- → ?
Version: Firefox 14 → Firefox 13
No, I don't think backing out would have much risk.
(Assignee)

Comment 14

5 years ago
Created attachment 617536 [details] [diff] [review]
backout patch for trunk and aurora 14
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #617536 - Flags: review?(peterv)
(Assignee)

Updated

5 years ago
Attachment #617536 - Attachment description: patch for trunk → backout patch for trunk
(Assignee)

Comment 15

5 years ago
Created attachment 617539 [details] [diff] [review]
backout patch for beta 13

[Approval Request Comment]
Regression caused by (bug #): 734503

User impact if declined: Touch events broken in XUL Fennec

Testing completed (on m-c, etc.): Not yet landed on m-c.  Existing automated  tests cover the code touched by this patch.

Risk to taking this patch (and alternatives if risky): Low-risk backout that reverts the TouchList class from using new-style binding to old-style bindings.

String changes made by this patch: None.
Attachment #617539 - Flags: review?(peterv)
Attachment #617539 - Flags: approval-mozilla-aurora?
Attachment #617539 - Flags: review?(peterv) → review+
Attachment #617536 - Flags: review?(peterv) → review+
(Assignee)

Updated

5 years ago
Attachment #617536 - Attachment description: backout patch for trunk → backout patch for trunk and aurora 14
Attachment #617536 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Attachment #617539 - Attachment description: backout patch for aurora → backout patch for beta 13
Attachment #617539 - Flags: approval-mozilla-aurora? → approval-mozilla-beta?
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9c0e1f71c15b
Target Milestone: --- → Firefox 15
https://hg.mozilla.org/mozilla-central/rev/c7bb8bb7d7a0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
tracking-firefox13: ? → +
Comment on attachment 617536 [details] [diff] [review]
backout patch for trunk and aurora 14

[Triage Comment]
Approved for Aurora 14.
Attachment #617536 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 617539 [details] [diff] [review]
backout patch for beta 13

and Beta 13
Attachment #617539 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 20

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/064758fe4026
https://hg.mozilla.org/releases/mozilla-beta/rev/7e8c20249a4f

This did *not* land in time for 13.0b1 build 1.  I'm not sure whether we should hold the build or respin for this...
status-firefox13: affected → fixed
status-firefox14: affected → fixed

Comment 21

5 years ago
Verified that touch events work again in 15.0a1 XUL Nightly from today.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.