no longer jump to Flash-Links with #

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: johns)

Tracking

({regression})

9 Branch
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regressed by Bug 622199)

(Reporter)

Description

6 years ago
This is spun off from Bug 742262

no longer jump to Flash-Links like
http://www.in-tanz.de/a/j/poly/poly-9.php#zwei
All other browsers resp. earlier FF do jump correctly to frame / reference #zwei.

Reproducible: Always

Steps to reproduce:
1. Open http://www.in-tanz.de/test-ff/test-ff.php
2. Click link "Problem with links in Flash with a reference to a special frame "
3. Click any Animation button

Actual results:
  no longer jump to Flash-Links with #.

Expected results:
  Should jump.
  Should handle # properly.


Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/0a6d1368cd97
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110914 Firefox/9.0a1 ID:20110914064528
Fails:
http://hg.mozilla.org/mozilla-central/rev/f483978fe878
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110914 Firefox/9.0a1 ID:20110914120949
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0a6d1368cd97&tochange=f483978fe878

Regressed by:
262cfa5c56ae	Josh Aas — Bug 622199: Add support for NPNVdocumentOrigin, ability to pass document origin directly to NPAPI plugins. r=bz

(Please set 622199 to block, because lack of right)
(Reporter)

Comment 1

6 years ago
This also happen in linux
http://hg.mozilla.org/mozilla-central/rev/e636439e342f
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120411 Firefox/14.0a1 ID:20120411030716
OS: Windows 7 → All
(Reporter)

Updated

6 years ago
Whiteboard: regressed by Bug 622199

Updated

6 years ago
Blocks: 622199

Comment 2

6 years ago
Dear Madam or Sir,
I am a bit disappointed. FF13 was published lately and still shows both flaws.
My customers are “not amused” to find that now at least five versions of Firefox (9 to 13) cannot cope with flash or pop ups properly (Bugs 743552 and 742262).
If I can be of any help, please let me know.
Is there any solution to be expected in the near future?
I do know that you are all volunteers. But until now, no one seems to be officially assigned to these problems. “Assigned To: Nobody”. Or am I mistaken in this respect?
A short reply would be appreciated.
With kind regards,
in-Tanz
I just tried the steps from comment 0, and they work fine for me on Mac...

Is this a matter of Flash plug-in version, or is something else going on here?  I don't see why bug 622199 would have affected the behavior here, btw.  It just exposed a new API to allow Flash to find out the page origin!
(Reporter)

Comment 4

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #3)
> I just tried the steps from comment 0, and they work fine for me on Mac...
> 
> Is this a matter of Flash plug-in version, or is something else going on
> here?  I don't see why bug 622199 would have affected the behavior here,
> btw.  It just exposed a new API to allow Flash to find out the page origin!

Actual:
These links jump to same content in Firefox.
All links are 1.90-Grad-...

Expected:
1st link #zwei should be "2.Dame lauft..."
2nd link #drei should be "3.Herr lauft..."
3rd link #vier should be "4.Dame lauft..."
4th link #fuenf should be "5.Herr lauft..."
5th link #sechs should be "6.Ausdrehen..."
(Reporter)

Comment 5

6 years ago
Boris, Please check the content of each links.
Yes.  When I do the steps from comment 0, on Mac, I see the "expected" content from comment 4.

Comment 7

6 years ago
I added new test cases to prove, that the problems do not only occur in pop ups, but in the normal browser window as well.
www.in-tanz.de/test-ff/test-ff.php
Still works fine for me on Mac...

I don't seem to have Flash on my Linux box, sadly.
(Reporter)

Comment 9

4 years ago
If you can not check the patch of Bug 622199 on Linix, 
You should not mark review+ at least on Linix!!
Flags: needinfo?(bzbarsky)
(Reporter)

Comment 10

4 years ago
maybe duplication of Bug 995896
> If you can not check the patch of Bug 622199 on Linix, 

I think you're confusing the roles of patch author and reviewer...

> maybe duplication of Bug 995896

Yes, possible.

Josh, can you please take a look here?
Flags: needinfo?(bzbarsky) → needinfo?(joshmoz)
> Yes, possible.

Actually, 100% certain: it's the same URL.

Comment 14

4 years ago
I have not looked at this code in a while. Hopefully jschoenick can look.
Assignee: nobody → jschoenick
Flags: needinfo?(joshmoz)
(In reply to Boris Zbarsky [:bz] from comment #3)
> I don't see why bug 622199 would have affected the behavior here,
> btw.  It just exposed a new API to allow Flash to find out the page origin!

I don't see actual anchors in the page - apparently this is using anchors to have Flash jump to different frames.
If that is the case, then Flash may regress when NPNVdocumentOrigin is available?
(Assignee)

Comment 16

4 years ago
Is flash perhaps erroneously using NPNVdocumentOrigin as the full page URL, and thus no longer able to see the hash value? That's the only thing I can think of that would cause us passing it to regress things.

Comment 17

4 years ago
Anyone care to take a plugin log and see what calls are being made? NSPR logging:

NSPR_LOG_MODULES=Plugin:5,PluginNPP:5,PluginNPN:5,IPCPlugins:5
(Reporter)

Comment 18

4 years ago
I cannot reproduce the problem in Firefox10.0, esr24.5.0 as well as Nightly32.0a1 + Flash Player 13.0.0.214 .
It seems this was fixed by Flash side.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.