Last Comment Bug 743748 - Reenable ANGLE shader translation on Android
: Reenable ANGLE shader translation on Android
Status: RESOLVED FIXED
webgl-conformance webgl-next
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
Depends on: 748654
Blocks: 719232 749295
  Show dependency treegraph
 
Reported: 2012-04-09 11:27 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-07-09 13:45 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reenable shader translation on android (1.57 KB, patch)
2012-04-26 13:13 PDT, Benoit Jacob [:bjacob] (mostly away)
jgilbert: review+
jgilbert: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Benoit Jacob [:bjacob] (mostly away) 2012-04-09 11:27:34 PDT
In bug 709947, we turned off shader translation on Android, with this comment:

// see bug 709947. On Android, we can't use the ESSL backend because of strange crashes (might be
// an allocator mismatch). So we use the GLSL backend, and discard the output, instead just passing
// the original WebGL shader source to the GL (since that's ESSL already). The problem is that means
// we can't use shader translations on Android, in particular we can't use long identifier shortening,
// which means we can't reach 100% conformance. We need to fix that by debugging the ESSL backend
// memory crashes.

We should figure out what really causes these crashes (allocator mismatch?) and fix them, and re-enabled shader translation. It's a requirement for full conformance on Android, and it's important for stability/security.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2012-04-26 13:13:53 PDT
Created attachment 618775 [details] [diff] [review]
reenable shader translation on android
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2012-04-30 14:45:40 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/4bb0aa38c2d4
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2012-04-30 15:50:19 PDT
Comment on attachment 618775 [details] [diff] [review]
reenable shader translation on android

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: we strongly suspect that the lack of shader translation on android is the cause of webgl crashes. in particular, without shader translation, we can't do long identifier mapping. this also prevents us from being webgl conformant on android.
Testing completed (on m-c, etc.): inbound
Risk to taking this patch (and alternatives if risky): I am rather confident that bug 748654 removed the reason why we had to disable shader translation on android. So this should be safe. If we see a surge of crashes, we'll re-disable.
String changes made by this patch: none
Comment 4 :Ehsan Akhgari (out sick) 2012-05-02 21:17:13 PDT
https://hg.mozilla.org/mozilla-central/rev/4bb0aa38c2d4
Comment 5 Alex Keybl [:akeybl] 2012-05-03 09:18:44 PDT
Comment on attachment 618775 [details] [diff] [review]
reenable shader translation on android

[Triage Comment]
Android only, and we'll disable if we see more crashiness with WebGL. Approved for Aurora 14.
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2012-07-09 13:45:58 PDT
Oops, apparently this was never backported to 14, sorry... anyway 14's been out for a while on Android,  and this doesn't matter for non-Android platforms.

Note You need to log in before you can comment on or make changes to this bug.