Closed Bug 744097 Opened 10 years ago Closed 8 years ago

Indicate that app has in-app payments

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: krupa.mozbugs, Assigned: mhanratty)

References

()

Details

(Keywords: uiwanted, Whiteboard: [ddn])

steps to reproduce:
1. Go to https://marketplace-dev.allizom.org/en-US/app/in-app-payment-tester/?src=search
2. Notice the Install button.

expected behavior:
Since the app has in-app payments, we inform the user about this in some manner.


observed behavior:
Currently the user has no way of knowing that the app has in-app payments
Bryan, Diane: What do you want to do here?
Whiteboard: [ddn]
At the time of installing this app, the user doesn't need to know that the app has in-app payments.  It is only when the user gets to the last level and needs to buy the in-app purchase to get more levels, that they should be prompted in the app to pay.  If their wallet is not setup at the in-app purchase time, then they will be promoted to setup their wallet.  If the wallet is already setup at the time of in-app purchase, then we're all set to go.

So I guess what I'm saying is that the user will never have to know that the app has in-app payments when they are in the marketplace interface.

Bryan - any other thoughts?
I see no problem with displaying that an app would use in-app payments. 

My kids click on everything in apps and I've had to stop them doing in-app payments before. Having a way to filter out apps that don't have in-app payments is one example. 

Knowing there are in-app payments might also affect my decision to install in the first place.
We're collecting the data when the developer submits the app - telling the user before they install feels like a valid use for it.
Priority: -- → P4
Note to cvan: We should possibly indicate something on /search/
(In reply to Andy McKay [:andym] from comment #3)
> I see no problem with displaying that an app would use in-app payments. 

Agreed.  I don't think we need a filtering mechanism here for apps that have in-app payments but we could do some kind of icon or note to let people know there are in-app payments available.

> My kids click on everything in apps and I've had to stop them doing in-app
> payments before. Having a way to filter out apps that don't have in-app
> payments is one example. 

I'd say this is a separate problem from filtering/listing the information as much as enabling / disabling in-app payments to prevent unauthorized usage.  

Something like:
  [x] I have kids, so double check and require my password for in-app purchases

Even though this is a non-parent speaking to a parent I'm pretty sure if your kids want Angry birds you're going to get it so filtering out that app because it has in-app payments won't help you much.  Really I think you want to find the apps they want and then control the in-app purchasing afterward.

> Knowing there are in-app payments might also affect my decision to install
> in the first place.

Agreed, an indicator and possibly a future option to disable those for this app seems like the right path forward to me.
What is the indicator?  Where does it go?
Blocks: 752013
No longer blocks: 735054
Blocks: 766201
No longer blocks: 752013
Keywords: uiwanted
CC'ing Maria for ideas on where to put this info
Component: Public Pages → Consumer Pages
Product: addons.mozilla.org → Marketplace
QA Contact: web-ui → consumer-pages
Version: unspecified → 1.0
(In reply to Chris Van Wiemeersch [:cvan] from comment #8)
> CC'ing Maria for ideas on where to put this info

Noted. I'll think about it for a bit and get back to you.
Blocks: 766199
No longer blocks: 766199
The indicator should go on the app details page. If we are using any sort of symbol or other graphic we will need visual design help - is that what the intention was? The option would be to simply use text - "This app uses in-app purchasing" or something similar.
(In reply to Maria Sandberg [:mushi] from comment #10)
> The indicator should go on the app details page. If we are using any sort of
> symbol or other graphic we will need visual design help - is that what the
> intention was? The option would be to simply use text - "This app uses
> in-app purchasing" or something similar.

Yep, that's the intention.
Assignee: nobody → msandberg
What did we decide here?
UX, can you chime in here please?
Yes, we would like to do this. I asked David Bialer to add it to other changes we want to make for the app details screen in Q3.
Is there a timeline for this? Q3 is going to be over before we know it.
Flags: needinfo?(dbialer)
Thoughts on changes to app details for Q3
1. indicator of in-app payment in app details P3 (other app stores do this, but not a high priority)
2. indicator of size of download for packaged apps (need more thought) P3 (has been requested to know a 'size' before an app is downloaded so that the user understand they need to use data a secondarily so that they know how much space on the device it takes up (though this is a separate issue)
3. screenshot improvements (better space utilization) P1 - most used feature in app details
4. indicator of whether app supports offline usage - P2 - request from a partner.

I haven't had time to write a spec.
Flags: needinfo?(dbialer)
Let it be said (re: #2) that when you press the Install button, it will tell you the size of the packaged app before the app is installed.
Assignee: msandberg → mhanratty
ESRB shows this information.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.