Closed Bug 744162 Opened 10 years ago Closed 10 years ago

Update the Windows RDF for the Flash Player 11.2.202.233 Release

Categories

(Toolkit Graveyard :: Plugin Finder Service, defect)

x86_64
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jpfeiffe, Assigned: cbook)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

A new Flash Player will be released on Thursday 4/12/2012 at 10am PST:

RDF changes for 32-bit Windows systems:

<pfs:version>11.2.202.232</pfs:version>
<pfs:InstallerHash>sha256:9f43300386c66f76427d55584a6640993e8377cf0e0865832dee8f0e6c32e20c</pfs:InstallerHash>

RDF changes for 64-bit Windows systems:

<pfs:version>11.2.202.232</pfs:version>
<pfs:InstallerHash>sha256:ef0851f43a8b2b9c1295e83b176774ab45d3aa3b689a794a8cb1d98f061be397</pfs:InstallerHash>
Component: Untriaged → Plugin Finder Service
Product: Firefox → Toolkit
QA Contact: untriaged → plugin.finder
taking
Assignee: nobody → cbook
Group: mozilla-corporation-confidential
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Sorry for the late change, we had to rebuild. Please use the following RDF changes. Also, the release date has moved out to Friday 4/13/2012 at 10am PST:

RDF changes for 32-bit Windows systems:

<pfs:version>11.2.202.233</pfs:version>
<pfs:InstallerHash>sha256:94887c02a7bc40c844798c3ca840d53ead56203410d2a1cf49f1f557773a41a2</pfs:InstallerHash>

RDF changes for 64-bit Windows systems:

<pfs:version>11.2.202.233</pfs:version>
<pfs:InstallerHash>sha256:d60c42140f5612a818e364690f2d6ee021a45cabc0f2cfffe1d010e99939c374</pfs:InstallerHash>
Summary: Update the Windows RDF for the Flash Player 11.2.202.232 Release → Update the Windows RDF for the Flash Player 11.2.202.233 Release
Attachment #614300 - Flags: review?(clouserw)
(In reply to John Pfeiffer from comment #2)
> Sorry for the late change, we had to rebuild. Please use the following RDF
> changes. Also, the release date has moved out to Friday 4/13/2012 at 10am
> PST:
> 
> RDF changes for 32-bit Windows systems:
> 
> <pfs:version>11.2.202.233</pfs:version>
> <pfs:InstallerHash>sha256:
> 94887c02a7bc40c844798c3ca840d53ead56203410d2a1cf49f1f557773a41a2</pfs:
> InstallerHash>
> 
> RDF changes for 64-bit Windows systems:
> 
> <pfs:version>11.2.202.233</pfs:version>
> <pfs:InstallerHash>sha256:
> d60c42140f5612a818e364690f2d6ee021a45cabc0f2cfffe1d010e99939c374</pfs:
> InstallerHash>

np, updated my patch.
I assume it's a bad thing if this goes out today?
The new installers will be deployed to production today (4/12) around 5pm PST, so you should feel free to deploy the RDF changes as soon as the new installers become available.
ok.  we update at 2pm so this will miss that window.  Thanks.
released - clearing flag
Group: mozilla-corporation-confidential
https://github.com/mozilla/zamboni/commit/3fa8652b633cea11fc49264ac867685c0be544a9
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Attachment #614300 - Flags: review?(clouserw)
Wil, there seems to be a problem.

https://pfs.mozilla.org/plugins/PluginFinderService.php?mimetype=application%2Fx-shockwave-flash&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=20120312181643&clientOS=Windows%20NT%206.1;%20WOW64&chromeLocale=en-US&appRelease=11.0

still lists a old 11.1 version for flash not the latest one. Do we have caching issues again ?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 745373
This missed the 2pm window on Thursday - the next one is next Thursday at 2pm.  If this is critical we can try to get it out before then.  Let us know.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
oremj knows how the rewrites go
can we get this fixed asap?
Yes, it is using services/pfs.py
(In reply to Jeremy Orem [:oremj] from comment #16)
> Yes, it is using services/pfs.py

Could you correct it so it points to the views.py view specified in bug 750112 comment 2?  Not sure why/how it changed.
Severity: normal → critical
(In reply to Matthew N. [:MattN] from comment #17)
> (In reply to Jeremy Orem [:oremj] from comment #16)
> > Yes, it is using services/pfs.py
> 
> Could you correct it so it points to the views.py view specified in bug
> 750112 comment 2?  Not sure why/how it changed.

We've never used the pfs in views.py in production. We went from the php version to services/pfs.py.
Patch to bring pfs.py up-to-date (Java and Flash; Director is fine). Please review and push asap.
Attachment #614300 - Attachment is obsolete: true
Attachment #620450 - Flags: review?(clouserw)
Attachment #620450 - Flags: review?(clouserw) → review+
this is pushed to production.  thanks
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Thanks, Wil, much appreciated. Will test and verify.
i hate to do this, but need to reopen this.

In a live test for java and shockwave it stills displays the old stuff like old java 29 update and old flash version :(

https://pfs.mozilla.org/plugins/PluginFinderService.php?mimetype=application%2Fx-shockwave-flash&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=20120420145725&clientOS=Windows%20NT%206.1&chromeLocale=zh-CN&appRelease=12.0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Resolved by the AMO push yesterday plus the follow-up fix in bug 751984
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Thanks everyone, quickest turnaround yet!
Duplicate of this bug: 752169
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.