Reading a msg with attachments crashes.

VERIFIED DUPLICATE of bug 74441

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 74441
18 years ago
14 years ago

People

(Reporter: Suresh, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.9
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I crash in imagelib if I read a msg with attachments.

Build: Today's commercial build on Win NT.

Stack trace: 
 
  nsImageFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsImageFrame.cpp, line 974]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsBlockFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6573]
     
  nsBlockFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6451]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsBlockFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6573]
     
  nsBlockFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6451]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsContainerFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
152]
     
  nsTableCellFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line 
329]
     
  nsTableRowFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
552]
     
  nsTableRowFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
500]
     
  nsTableRowGroupFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 282]
     
  nsTableRowGroupFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 231]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsContainerFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
152]
     
  nsTableFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 1469]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsTableOuterFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
370]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsBlockFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6573]
     
  nsBlockFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6451]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsBlockFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6573]
     
  nsBlockFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6451]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsBlockFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6573]
     
  nsBlockFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6451]
     
  nsContainerFrame::PaintChild 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
208]
     
  nsContainerFrame::PaintChildren 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
152]
     
  nsHTMLContainerFrame::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLContainerFrame.cpp, line 
109]
     
  PresShell::Paint 
                                          
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4843]
     
  nsView::Paint 
                                          
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 277]
     
  nsViewManager::RenderDisplayListElement 
                                          
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1394]
     
  nsViewManager::RenderViews 
                                          
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1319]
     
  nsViewManager::Refresh 
                                          
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 885]
     
  nsViewManager::DispatchEvent 
                                          
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1912]
     
  HandleEvent 
                                          
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     
  nsWindow::DispatchEvent 
                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 699]
     
  nsWindow::DispatchWindowEvent 
                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 721]
     
  nsWindow::OnPaint 
                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3826]
     
  nsWindow::ProcessMessage 
                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2833]
     
  nsWindow::WindowProc 
                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 951]
     
  USER32.dll + 0x19d0 (0x77e719d0) 
                                           
     
  USER32.dll + 0x1982 (0x77e71982) 
                                           
     
  ntdll.dll + 0x163a3 (0x77f763a3)
crasher -> 0.9
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9

Comment 2

18 years ago
Build 2001-04-04-04: NT4
Build 2001-04-04-12: Linux RH 6.2
I also crash on windows and linux. I'm having problems connecting to Cyclone 
so I can't compare the stack traces. Is this the same problem that Suresh 
reported?

1. Select a message with an attachment(gif or txt)
2. Select File|Attachments and it displays the name of the attachment with an 
arrow pointing to the right but I don't see any other menu items.
3. Just place the cursor on the name of the attachment

Actual Results: It crashes

Expected Results: No crash. Also, is there something else that should be 
displayed beyond the name of the attachment? Possibley Open and Save? I noticed 
if I go to the Message pane and select the attachment icon it displays the name 
of the file. After highlighting the name of the file it then displays two more 
choices (Open, Save). 

Additional Information:
- Mac: Does not crash but after the attachment is highlighted it appears to draw 
another menu item but doesn't complete. It looks like a sliver.

Comment 3

18 years ago
stack looks like a dup of a bug I filed that got marked a dup of 74441.

*** This bug has been marked as a duplicate of 74441 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.