Closed Bug 74441 Opened 24 years ago Closed 24 years ago

crash loading mail message

Categories

(Core :: Graphics: ImageLib, defect)

defect
Not set
critical

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: waterson, Assigned: pavlov)

References

Details

(Keywords: crash, Whiteboard: [imagelib])

Attachments

(1 file)

I crash loading a mail message (which I'll attach) trying to dereference a null
mImageRequest in nsImageFrame::Paint().
Keywords: crash, mozilla0.9
To reproduce,

1. Save attached test case (04/02/01 14:25) in your ``Local Mail'' folder
   as ``Bug''
2. Start mail/news
3. Open local folders, click on the ``Bug'' folder
4. Open the message.

Expected: message displays
Actual: crash

cc'ing mscott, as this may have to do with decoding, cache, etc. Probably
somebody on mail QA should be cc'd too, but I'm not sure who that'd be these days.
this is a dup of a bug i filed on pav (or at least re-assigned to him last
week). I'll try to dig it up and mark it appropriately. 
*** Bug 74442 has been marked as a duplicate of this bug. ***
*** Bug 74464 has been marked as a duplicate of this bug. ***
*** Bug 74418 has been marked as a duplicate of this bug. ***
the code has been patched to not crash anymore, but the underlying problem still
exists.

see #74471
Any progress on this? I still crash on about 1 message a day with this stack.
Keywords: mailtrack, nsbeta1
I'm still seeing this too...the null ptr check of Seth's didn't take apparently.
 Pav this is one the bugs I was mentioning today when i said did you fix our
crashers yet =).
adding [imagelib] keyword to status
Whiteboard: [imagelib]
*** Bug 75951 has been marked as a duplicate of this bug. ***
Severity: major → critical
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 75240 has been marked as a duplicate of this bug. ***
*** Bug 75422 has been marked as a duplicate of this bug. ***
75951 contains a stack trace.
i've added checks all over that code so it shouldn't every try and dereference a 
null mImageRequest.  can someone please verify the crash isn't happening 
anymore?
Keywords: qawanted
Pavlov, you lazy bum, follow the repro instructions! I gave you the test case on 
a tray with a pretty yellow easter ribbon!
The message in http://bugzilla.mozilla.org/show_bug.cgi?id=74464 which was
marked a dup of this bug, still crashes in 2001041704 which should have all of
the changes you checked in last night.
I am no longer seeing the crash in the message I used to file 74464 so I think
this works.  I'm going to mark WFM.  If anyone else is still seeing this, please
reopen.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → WORKSFORME
I'm not seeing it win XP build 2002013003, marking verified
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: