Closed Bug 744189 Opened 8 years ago Closed 8 years ago

Can't open bookmarks from the Firefox button

Categories

(Toolkit :: Places, defect)

14 Branch
x86_64
Windows NT
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla14

People

(Reporter: KWierso, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file)

When I click a bookmark from the Firefox button's bookmarks submenu, the bookmark doesn't open, and I get the following error logged in my error console:

Timestamp: 4/10/2012 4:29:23 PM
Error: aView is undefined
Source File: resource:///modules/PlacesUIUtils.jsm
Line: 655

This is happening for me in safe mode on the most recent win32 Nightly build.
I'm not sure offhand when this started to not work, as I rarely use the Firefox button's bookmarks menu.
Regression window(m-c)
works:
http://hg.mozilla.org/mozilla-central/rev/9ca66ce2672f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120409 Firefox/14.0a1 ID:20120409031240
fails:
http://hg.mozilla.org/mozilla-central/rev/7227004c8893
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120409 Firefox/14.0a1 ID:20120409100742
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9ca66ce2672f&tochange=7227004c8893


Regression window(m-c)
works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4ea78fe84b7c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120406 Firefox/14.0a1 ID:20120406045845
fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/690e77288e98
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120406 Firefox/14.0a1 ID:20120406064443
pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4ea78fe84b7c&tochange=690e77288e98

Regresed by:
690e77288e98	Asaf Romano — Bug 739451 - Don't rely on XPConnect-magic for getting the owner window of a places view (Required for compartment-per-global work). r=mak
Blocks: 739451
Component: Bookmarks & History → Places
Keywords: regression
Product: Firefox → Toolkit
QA Contact: bookmarks → places
Version: unspecified → 14 Branch
I can reproduce this bug too. Additionally, if IE View (1.5.0) is installed (and enabled), bookmark toolbar's bookmark items don't work too. In other words, you can use bookmark toolbar without IE View.
I can reproduce this bug too on the latest Nightly. Bookmarks work fine from toolbar of bookmarks button on bookmarks toolbar but not from Firefox Menu.
Attached patch Untested fixSplinter Review
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #613890 - Flags: review?(mak77)
You can change OS to all. Seeing this on Linux 64 bits. Kinda annoying bug.
For me, it's only middle-click that doesn't work - left-click and right-click work as normal.

I use Ie View Lite, no issues with the Bookmarks Toolbar.

Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120410 Firefox/14.0a1 ID:20120410075652
Now only right-click is working.
Comment on attachment 613890 [details] [diff] [review]
Untested fix

Review of attachment 613890 [details] [diff] [review]:
-----------------------------------------------------------------

tested working and makes sense.
Attachment #613890 - Flags: review?(mak77) → review+
Duplicate of this bug: 744511
https://hg.mozilla.org/mozilla-central/rev/9413f184e70e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 745175
Duplicate of this bug: 745400
This fix don't work for me in the latest win64 2012-04-21 nightly or 2012-04-22 mozilla-central tinderbox builds. Clicking left on the bookmark entry dont't open a website, clicking right-open works.
For those seeing the issue with IE View 1.5 and FF 14 alpha, there's an IE View build at https://github.com/downloads/paulroub/ieview/ieview.xpi that addresses the issue; it's the same issue addressed by the patch attached to this bug, but IE View's fault in this case.  Feedback is welcome before I push the fix into a public release.
(In reply to Klaus P. Kuhlemann from comment #14)
> This fix don't work for me in the latest win64 2012-04-21 nightly or
> 2012-04-22 mozilla-central tinderbox builds. Clicking left on the bookmark
> entry dont't open a website, clicking right-open works.

Does safe mode help? You may have a prolem with an add-on.
http://support.mozilla.org/kb/Safe+Mode
(In reply to Paul Roub from comment #15)
IE View 1.5, which I used often as web-designer, has been the problem. Uninstalling that resolves the bug. Your 1.5.02 build works for me perfectly. I suggest that you'll release the patch.
You need to log in before you can comment on or make changes to this bug.