Non-ascii chars of list name in Collected Addresses look like 2 single-byte chars

RESOLVED INVALID

Status

MailNews Core
Internationalization
RESOLVED INVALID
17 years ago
9 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

({intl})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
**** observed with 2001-04-02 build ****
This bug depends on fixes for 54521 and 68874.Now when nscp6 autocomplete 
against mail list it adds the domain name to the mail list description. This 
bug and the stripping of spaces makes non-ascii list names go out wrong.Then in 
collected addresses we see the 8 bit non-ascii list names represented with two 
single-byte chars.
Steps to reproduce:
- open Address Book;
- create a list with non-ascii name and non-ascii chars in the description 
field;
- open new mail, choose a new list when it autocompletes;
- now notice that the domain name is appended ( bug # 54521);
- send it out;
- open Collected AB;
//note: the list name would look like "lálistdèmesà mis" instead of   "lá 
líste dé mes âmis"
(Assignee)

Comment 1

17 years ago
Could you attach a screen shot?
(Reporter)

Comment 2

17 years ago
Created attachment 29526 [details]
see the attached scree shot
(Assignee)

Comment 3

17 years ago
Looking at the screen shot, the first three lines shows e-mail address at "Name"
column and name in "Email" column. Is that also a problem?
(Reporter)

Comment 4

17 years ago
twhen you create a new mail list it shows in the Personal AB in the correct way
but when sent out the domain name gets appended so in the Collected AB you see
it with the domain name in the display field ( known problem)
(Assignee)

Comment 5

17 years ago
Reassign to chuang.
Assignee: nhotta → chuang
Keywords: intl
(Reporter)

Comment 6

17 years ago
now the problem with adding domain name to mailing list is fixed, the incorrect 
display of non-ascii chars in the Collected AB is still showing up

Updated

17 years ago
QA Contact: ji → marina
(Assignee)

Comment 7

16 years ago
Reassign to nhotta.

Does this still happen?
Assignee: chuang → nhotta
(Reporter)

Comment 8

16 years ago
yes, it does because the list name expands to its description and is placed into
the email colomn, so it is interprated there as an incorrect email address> with
2 single byte chars.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2alpha
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.2alpha → ---
Product: MailNews → Core
Product: Core → MailNews Core
This is no longer an issue - Mailing lists in the address book don't get collected into the collected address book (and shouldn't be), and we also solved the issues with collection of names when sending to non-ascii display names.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.