Last Comment Bug 744666 - Text in Text-box when scrolled doesn't render correctly
: Text in Text-box when scrolled doesn't render correctly
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 14 Branch
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 744607
Blocks: 733607
  Show dependency treegraph
 
Reported: 2012-04-11 17:51 PDT by rob64rock
Modified: 2012-12-06 03:35 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description rob64rock 2012-04-11 17:51:43 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120411 Firefox/14.0a1
Build ID: 20120411030716

Steps to reproduce:

I'm using Win32 2012/04/11 Fx Nightly build, on WinXp only with D3D9 Accelerated layers and Smooth-scrolling enabled by default.

1.) Go here: http://forums.mozillazine.org/

2.) Type a paragraph or more of text in the thread topic comment 'Post A Reply' text-box at the bottom of a thread topic page.

3.) Select: 'Preview'

4.) Now scroll through the text in text-box with mouse-wheel or something similar.


Actual results:

See video here:
http://youtu.be/kU0f5TCjn2g



Expected results:

Text in text-box should of been rendered correctly instantly.


Note: Problem doesn't exist in Fx SafeMode or when just disabling Fx HWA.
Comment 1 gabe 2012-04-11 20:25:44 PDT
confirmed
Comment 2 gabe 2012-04-12 09:06:15 PDT
seems to be working again
Comment 3 rob64rock 2012-04-12 13:36:16 PDT
(In reply to gabe from comment #2)
> seems to be working again
Still occurs for me on WinXP 32bit on Nightly 20120412 Firefox/14.0a1 Cset 8eb367e5b053.

Ensure you have Fx HWA enabled and if are re-enabling Fx HWA restart browser before testing to re-confirm using the STR mentioned above.
Comment 4 rob64rock 2012-04-12 14:50:00 PDT
(In reply to rob64rock from comment #3)
> (In reply to gabe from comment #2)
> > seems to be working again
> Still occurs for me on WinXP 32bit on Nightly 20120412 Firefox/14.0a1 Cset
> 8eb367e5b053.
> 
> Ensure you have Fx HWA enabled and if are re-enabling Fx HWA restart browser
> before testing to re-confirm using the STR mentioned above.

I confirmed using (NVIDIA GeForce 7800 GS ) using driver: NVIDIA Forceware 296.10 WHQL XP

Also I'm not sure if this is OS or Graphic Card specific, so if you can confirm please specify your OS and Graphic Card + driver.
Comment 5 Jim Jeffery not reading bug-mail 1/2/11 2012-04-12 15:04:34 PDT
Not just XP, I can repo here in bugzilla by pasting in a bunch of text in the text-box and scrolling up/down.  The test will fade, and appear clipped.  Interestingly, if I move the mouse cursor out of the text-box the text instantly clears. 
Takes several scrolls up/down using mouse-wheel to reproduce and the cursor has to stay in the test-box. Also sometimes will appear dragging the scroll-bar, so perhaps the cursor does not need to stay in the text-box, but in both cases, moving the cursor out of the text-box clears the text.

Win7 X64 here, running latest m-c hourly build based on cset: 
https://hg.mozilla.org/mozilla-central/rev/901dfde60183

Adapter DescriptionATI Radeon HD 3200 GraphicsVendor ID0x1002Device ID0x9610Adapter RAM256Adapter Driversaticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64Driver Version8.881.0.0Driver Date7-28-2011Direct2D EnabledtrueDirectWrite Enabledtrue (6.1.7601.17776)ClearType ParametersDISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300 ] DISPLAY4 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] WebGL RendererGoogle Inc. -- ANGLE (ATI Radeon HD 3200 Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)GPU Accelerated Windows1/1 Direct3D 10

        
AzureBackenddirect2d
Comment 6 gabe 2012-04-12 17:04:56 PDT
(In reply to rob64rock from comment #3)
> (In reply to gabe from comment #2)
> > seems to be working again
> Still occurs for me on WinXP 32bit on Nightly 20120412 Firefox/14.0a1 Cset
> 8eb367e5b053.
> 
> Ensure you have Fx HWA enabled and if are re-enabling Fx HWA restart browser
> before testing to re-confirm using the STR mentioned above.

i jinxed myself or something
Comment 7 Alice0775 White 2012-04-12 17:08:26 PDT
Confirmed with str comment #0 on
http://hg.mozilla.org/mozilla-central/rev/8eb367e5b053
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120412 Firefox/14.0a1 ID:20120412030726

Graphics
Adapter Description : ATI Radeon HD 4300/4500 Series
Vendor ID : 0x1002
Device ID : 0x954f
Adapter RAM : 512A
dapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version : 8.951.0.0
Driver Date : 3-8-2012
Direct2D Enabled : true
DirectWrite Enabled : true (6.1.7601.17776)
ClearType Parameters : Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200 
WebGL Renderer : Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows : 1/1 Direct3D 10
AzureBackend : direct2d

25a13d26509d	Robert O'Callahan — Bug 733607.
Comment 8 Alice0775 White 2012-04-12 17:12:11 PDT
Regression window(m-c)
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/b687cabf75a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120410 Firefox/14.0a1 ID:20120410122159
Can reproduce:
http://hg.mozilla.org/mozilla-central/rev/4db1292be760
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120410 Firefox/14.0a1 ID:20120410130200
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b687cabf75a1&tochange=4db1292be760



Regression window(m-i)
Cannot reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a235528adace
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120409 Firefox/14.0a1 ID:20120410041149
Can reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/25a13d26509d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120410 Firefox/14.0a1 ID:20120410054929
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a235528adace&tochange=25a13d26509d

Triggered by
25a13d26509d	Robert O'Callahan — Bug 733607.
Comment 9 Timothy Nikkel (:tnikkel) 2012-04-13 22:16:06 PDT
Someone should test a build that has bug 744607 fixed in it to see if this is fixed as well. As I am typing this bug 744607 is only on inbound.
Comment 10 Alice0775 White 2012-04-13 22:52:33 PDT
I cannot reproduce anymore in
http://hg.mozilla.org/integration/mozilla-inbound/rev/7623055c5171
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120413 Firefox/14.0a1 ID:20120413044513
Comment 11 Timothy Nikkel (:tnikkel) 2012-04-13 22:56:02 PDT
Let's call it fixed. Please reopen if that is not the case.
Comment 12 Vlad 2012-04-15 06:03:15 PDT
In 2012-04-14 Nightly lower lines are now rendered like upper lines before this change on WinXP SP3(d3d9 layers).
For example, if i use "sql" text-box in phpmyadmin 3.5.0 then scroll in it up and then down, bad rendered lines appears as it was earlier.

Note You need to log in before you can comment on or make changes to this bug.