Last Comment Bug 744607 - scroll causes lines in webpage
: scroll causes lines in webpage
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla14
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
Mentors:
: 744487 745263 745449 (view as bug list)
Depends on:
Blocks: 733607 744666
  Show dependency treegraph
 
Reported: 2012-04-11 14:52 PDT by xxbones21xx
Modified: 2012-12-06 03:35 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
lines in nightly.png (203.07 KB, image/png)
2012-04-11 14:52 PDT, xxbones21xx
no flags Details
fix (4.56 KB, patch)
2012-04-12 20:34 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
tnikkel: review+
Details | Diff | Splinter Review

Description xxbones21xx 2012-04-11 14:52:49 PDT
Created attachment 614181 [details]
lines in nightly.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120411 Firefox/14.0a1
Build ID: 20120411030716

Steps to reproduce:

I used the middle button to scroll through a webpage after Nightly's 4-11-12 update.


Actual results:

Its scrolled correctly but caused there to be lines appearing wear the page was scrolled.


Expected results:

Not this. Should have just scrolled and left the contents of the page untouched.
Comment 1 xxbones21xx 2012-04-11 21:34:13 PDT
When i removed multirow bookmarks toolbar plus, then lines didnt appear anymore.
Comment 2 Cork 2012-04-11 22:27:33 PDT
Caused by http://hg.mozilla.org/integration/mozilla-inbound/rev/25a13d26509d

Link to the mentioned extension https://addons.mozilla.org/en-US/firefox/addon/multirow-bookmarks-toolbarplus

Roc, is this a regression or just an incompatible extension?
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-04-11 22:45:24 PDT
Probably not the extension.
Comment 4 Timothy Nikkel (:tnikkel) 2012-04-11 23:05:05 PDT
Do we snap the clip rect everywhere properly in FrameLayerBuilder?
Comment 5 Christian Ascheberg 2012-04-12 00:24:03 PDT
I also notice this in current nightly build when scrolling iframes.
Possible duplicate: bug #744666
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-04-12 20:34:25 PDT
Created attachment 614669 [details] [diff] [review]
fix

We need to make sure that stuff outside the snapped clip rect isn't included in the layer's visible region. This patch does that.

The change to nsDisplayClip::GetBounds doesn't really matter --- nothing uses this snap output --- but it's more correct; mClip's edges can be snapped, but the edges of the bounds of the wrapped list cannot be snapped.
Comment 7 Timothy Nikkel (:tnikkel) 2012-04-13 01:37:24 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #6)
> The change to nsDisplayClip::GetBounds doesn't really matter --- nothing
> uses this snap output --- but it's more correct; mClip's edges can be
> snapped, but the edges of the bounds of the wrapped list cannot be snapped.

So technically it should just leave aSnap alone and let nsDisplayWrapList::GetBounds set it?
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-04-13 04:46:01 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e339ca6c2f11(In reply to Timothy Nikkel (:tn) from comment #7)
> (In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #6)
> > The change to nsDisplayClip::GetBounds doesn't really matter --- nothing
> > uses this snap output --- but it's more correct; mClip's edges can be
> > snapped, but the edges of the bounds of the wrapped list cannot be snapped.
> 
> So technically it should just leave aSnap alone and let
> nsDisplayWrapList::GetBounds set it?

I suppose, but it doesn't matter.
Comment 9 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-04-13 04:46:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e339ca6c2f11
Comment 10 Benoit Girard (:BenWa) 2012-04-13 16:00:51 PDT
*** Bug 745263 has been marked as a duplicate of this bug. ***
Comment 11 Benoit Girard (:BenWa) 2012-04-13 16:01:40 PDT
*** Bug 744487 has been marked as a duplicate of this bug. ***
Comment 12 Jeff Gilbert [:jgilbert] 2012-04-14 02:52:02 PDT
fwiw, this seems to be happening on my galexy tab, as well.
Comment 13 Marco Bonardo [::mak] 2012-04-14 06:22:33 PDT
https://hg.mozilla.org/mozilla-central/rev/e339ca6c2f11
Comment 14 Jim Jeffery not reading bug-mail 1/2/11 2012-04-14 12:58:49 PDT
*** Bug 745449 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.