Last Comment Bug 744880 - GC: make Relocatable HeapValue variant that does not trigger post barriers
: GC: make Relocatable HeapValue variant that does not trigger post barriers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks: 744270 745325 745326
  Show dependency treegraph
 
Reported: 2012-04-12 11:59 PDT by Terrence Cole [:terrence]
Modified: 2012-04-25 07:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (2.72 KB, patch)
2012-04-13 16:01 PDT, Terrence Cole [:terrence]
wmccloskey: review+
Details | Diff | Review

Description Terrence Cole [:terrence] 2012-04-12 11:59:13 PDT
This will be needed for HashTables that store HeapValues.
Comment 1 Terrence Cole [:terrence] 2012-04-13 16:01:16 PDT
Created attachment 614939 [details] [diff] [review]
v0

This one is easy, since we already split out EncapsulatedValue.
Comment 2 Terrence Cole [:terrence] 2012-04-24 15:09:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/4811711ec8b7
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-25 07:24:41 PDT
https://hg.mozilla.org/mozilla-central/rev/4811711ec8b7

Note You need to log in before you can comment on or make changes to this bug.