Closed Bug 744898 Opened 8 years ago Closed 8 years ago

Some Java applets not working using Nightly/Aurora builds

Categories

(Core :: Plug-ins, defect, critical)

13 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 736965

People

(Reporter: marcia, Assigned: johns)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Screenshot of error
Seen while running the latest nightly and latest Aurora. This works using the latest Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0. This machine has been updated to the latest Java version via the Apple software update: java version "1.6.0_31". I have also seen this in the lab on 10.7.4 and 10.5.8 nightly builds.

about:plugins shows     

File: JavaPlugin2_NPAPI.plugin
Version: 13.7.0

STR:
1. Load http://mainline.brynmawr.edu/Courses/cs110/spring2002/Applets/Smiley/Smiley.html
2. Receive error message in attached screenshot.
3. Browser hangs and you have to force quit.

The details tab gives the following additional information:

load: class Smiley.class not found.
java.lang.ClassNotFoundException: Smiley.class
	at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:252)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:249)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:179)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:160)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:690)
	at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3045)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1497)
	at java.lang.Thread.run(Thread.java:680)
Exception: java.lang.ClassNotFoundException: Smiley.class
load: class Smiley.class not found.
java.lang.ClassNotFoundException: Smiley.class
	at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:252)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:249)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:179)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:160)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:690)
	at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3045)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1497)
	at java.lang.Thread.run(Thread.java:680)
Exception: java.lang.ClassNotFoundException: Smiley.class
Needs a regression range for sure, but I did quickly go back to 20120409 trunk and it was broken in that build as well.
This doesn't happen with all Java applets, as far as I know.

For example http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html.

Marcia, please test with that and let us know your results.
Another site that doesn't work for me: http://csis.pace.edu/~bergin/Java/applets.htm

The site that Steven references works for me on my 10.6 machine using the latest nightly Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20120412 Firefox/14.0a1.
Summary: Java not working on Nightly/Aurora builds → Some Java applets not working using Nightly/Aurora builds
Here's the regression range I found on OS X 10.7.3, testing with both of Marcia's examples:

firefox-2012-02-29-03-11-08-mozilla-central
firefox-2012-03-01-03-11-35-mozilla-central

This range includes the patch for bug 406541, which has already been implicated in a couple of other similar-sounding Java bugs.
Assignee: nobody → jschoenick
Depends on: 745030
Version: Trunk → 13 Branch
OS: Mac OS X → All
Hardware: x86 → All
Marking dup of bug 736965

These have the same root cause
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736965
You need to log in before you can comment on or make changes to this bug.