Approved apps take a while to show up in Search results

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Points:
---
Dependency tree / graph

Details

(Whiteboard: [u=dev c=mkt-search p=], URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Search for "boa" or load https://marketplace-dev.allizom.org/en-US/search/?q=boa
2. Search for "GIS" or load  https://marketplace-dev.allizom.org/en-US/search/?q=GIS


expected behavior:
#1 returns https://marketplace-dev.allizom.org/en-US/app/seevans-underworld-adventur-11/status
#2 returns https://marketplace-dev.allizom.org/en-US/app/gis-cloud/


observed behavior:
Looks like free apps with in-app payments do not show up in search results

Note: both app are public.

Updated

7 years ago
Assignee: nobody → amckay
Priority: -- → P2
(Reporter)

Comment 1

7 years ago
This has nothing to do with app type. Looks like apps take a while to show up in search results after they have been approved.
Summary: Free apps with in-app payments do not show up in search results → Approved apps take a while to show up in Search results
I made an app public locally and looked at the celery output and confirmed that it triggers the re-indexing...

20:57:58 celery:INFO Got task from broker: addons.tasks.index_addons[08d16b3e-37fb-4546-9484-7b6d4df364e2] :/Users/rob/git/zamboni/vendor/lib/python/celery/worker/consumer.py:374
20:57:59 z.task:INFO Indexing addons 337160-337160. [1] :/Users/rob/git/zamboni/apps/addons/tasks.py:97
20:58:00 celery:INFO Task addons.tasks.index_addons[08d16b3e-37fb-4546-9484-7b6d4df364e2] succeeded in 1.25481200218s: None :/Users/rob/git/zamboni/vendor/lib/python/celery/worker/job.py:332
"a while" like you're on a dev site and it's slow or are we talking about days?
Target Milestone: --- → 6.5.2
(In reply to Wil Clouser [:clouserw] from comment #3)
> "a while" like you're on a dev site and it's slow or are we talking about
> days?

I witnessed a few cases where it wasn't indexed ever. Like after a day. But going to its Edit Listing page from the devhub and triggering another Save - and voila, it showed up in the search results.

Comment 5

7 years ago
In all my testing edit or pushing to public has triggered index_addons. No STR yet.
Target Milestone: 6.5.2 → 6.5.4
there have been general improvements in this area.  please reopen with STR if this still happens.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

7 years ago
STR:
1. Search for the app "Area tweet" in prod

observed behavior:
Search returns no results even though the app is public. See  https://marketplace.mozilla.org/en-US/app/area-tweet/
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

7 years ago
Assignee: amckay → nobody
Component: Public Pages → Search
Product: addons.mozilla.org → Marketplace
QA Contact: web-ui → search
Target Milestone: 2012-05-10 → 2012-05-24
Version: unspecified → 1.0
Depends on: 749335
I see it, also in search suggestions.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
Verified as fixed . Searched for "Area tweet" and also for a previously approved app , "Applicationtest" and it was instantly displayed in search results : http://screencast.com/t/2laJ4wiKggIM
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

6 years ago
This is  still happening. I approved https://marketplace-dev.allizom.org/app/in-app-payment-tester-4/ and it is still to show up in the consumer pages.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 11

6 years ago
Could this be due to general problems with celery on the dev server? But even if that's the case, we should make the system more reliable. Either be running some sort of scheduled integrity check to compare published apps with ES - or look at celery and see how it handles job failures / retries.
Priority: P2 → P3
Whiteboard: [u=dev c=mkt-search p=?]
Target Milestone: 2012-05-24 → ---

Updated

6 years ago
Whiteboard: [u=dev c=mkt-search p=?] → [u=dev c=mkt-search p=]
(In reply to krupa raj 82[:krupa] from comment #10)
> This is  still happening. I approved
> https://marketplace-dev.allizom.org/app/in-app-payment-tester-4/ and it is
> still to show up in the consumer pages.

This was because paid apps were automatically excluded in USA by default (since payments were previously available only in Brazil). I've since enabled payments in USA. And I was able to approve an app and see the app's respective document appear in ES immediately.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.