If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hotmail's "messenger" dropdown does not finish loading in Firefox 14

RESOLVED DUPLICATE of bug 736731

Status

Tech Evangelism Graveyard
English Other
RESOLVED DUPLICATE of bug 736731
6 years ago
3 years ago

People

(Reporter: Varun Vijayaraghavan, Unassigned)

Tracking

({regression})

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20120414 Firefox/14.0a1
Build ID: 20120414034341

Steps to reproduce:

I went to hotmail.com, and signed in.


Actual results:

When I click on the "messenger" drop down, the first section is always "Loading", and never completes.


Expected results:

It should load the list of online friends, or indicate there are none.
(Reporter)

Comment 1

6 years ago
This issue was present on earlier versions of Firefox too, say around FF8. But it was more sporadic, and I used to get around it by refreshing the page a few times. Now, it doesn't work at all.

Comment 2

6 years ago
I can reproducee 100%  in Aurora13.0a12 and Nightly14.0a1 but I cannot reproduce in Firefox12 beta and earlier.
And the following errors appear in Error console.

Error: Microsoft.Live.Core.Internal is undefined
Source file: https://secure.wlxrs.com/_D/F$Live.SiteContent.Messenger/4.4.1585/release/Microsoft.Live.Messenger.Services.Loader.js
Line: 149
Error: Microsoft.Live.Core.Internal is undefined
Source file: https://secure.shared.live.com/_D/F$Live.SiteContent.Messenger/4.4.1585/LocalStorage.html#domain=by164w.bay164.mail.live.com&loaderPath=https://secure.wlxrs.com/h2zXAoTCuYjg85Q3WXbx9Q/loader.cxp.js&channelNames=DefaultLocalStorageChannel;MessengerStorageChannel&cb:httpsApplication=true&cb:compatibility.microsoftAjaxPropertyNames=false&cs:messenger.loaderName=loader.cxp.js&cb:messenger.sameDomainEndpointsAsLocalEnabled=true&cs:market=en-jp&cs:messenger.loaderPath=https%3A%2F%2Fsecure.wlxrs.com%2Fh2zXAoTCuYjg85Q3WXbx9Q%2F&cs:compatibility.version=current&
Line: 218


Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/ed57abebd328
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303051507
Fails:
http://hg.mozilla.org/mozilla-central/rev/baec1efc87a4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120304 Firefox/13.0a1 ID:20120304031031
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ed57abebd328&tochange=baec1efc87a4

Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d43c3e308c82
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120302 Firefox/13.0a1 ID:20120303052207
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7c62688f88fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303053807
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d43c3e308c82&tochange=7c62688f88fa

Triggered by:
8cdce56098cd	Matheus Kerschbaum — Bug 687579 part 1: Remove globalStorage implementation. r=jst Bug 687579 part 1: Remove globalStorage implementation. r=jst
Blocks: 687579
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Firefox → Core
QA Contact: untriaged → general
Version: 14 Branch → 13 Branch
See also bug 736731.
Assignee: nobody → english-other
Component: DOM → English Other
Product: Core → Tech Evangelism
QA Contact: general → english-other
Version: 13 Branch → unspecified

Comment 4

6 years ago
Yes seems related to https://bugzilla.mozilla.org/show_bug.cgi?id=736731

I've notified the Windows Live Messenger teams
Has someone actually contacted Microsoft about this?  Or are we hoping that assignment to "Evangelism" will magically make this happen?

Requesting tracking; this seems like a pretty serious web compat regression....  Worse yet, since we let this sit for a full cycle we can't even really back out the relevant patch on beta.  :(
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
tracking-firefox15: --- → ?
I guess the evang in bug 736731 might end up covering this....
Depends on: 736731

Comment 7

6 years ago
Given comment 4, duping to bug 736731 (which is tracked for FF13).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
tracking-firefox13: ? → -
tracking-firefox14: ? → -
tracking-firefox15: ? → -
Resolution: --- → DUPLICATE
Duplicate of bug: 736731
Depends on: 764546
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.