Hotmail no longer auto-updates (due to "globalStorage" removal)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: Robert Claypool, Unassigned)

Tracking

({regression})

Details

(Whiteboard: [qa+])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120316 Firefox/14.0a1
Build ID: 20120316031151

Steps to reproduce:

Logged into my Hotmail account. Hotmail no longer automatically updates the list of emails and count in title bar. Does so in IE.



Expected results:

The web page should have checked for updates.
(Reporter)

Comment 1

5 years ago
Works in Build 2120303031033
Fails in Build 2120304031031

Comment 2

5 years ago
Regression window(m-c),
Works:
http://hg.mozilla.org/mozilla-central/rev/ed57abebd328
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303051507
Fails:
http://hg.mozilla.org/mozilla-central/rev/baec1efc87a4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303164007
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ed57abebd328&tochange=baec1efc87a4


Regression window(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d43c3e308c82
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120302 Firefox/13.0a1 ID:20120303052207
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7c62688f88fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303053807
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d43c3e308c82&tochange=55e360715d76

Triggered by:
8cdce56098cd	Matheus Kerschbaum — Bug 687579 part 1: Remove globalStorage implementation. r=jst Bug 687579 part 1: Remove globalStorage implementation. r=jst
Blocks: 687579
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: untriaged → general
Version: 14 Branch → 13 Branch

Updated

5 years ago
tracking-firefox13: --- → ?
Is this something we need to evangelize them about, basically?
Yes.
(Reporter)

Comment 5

5 years ago
There's an explanation missing here.
The explanation is that globalStorage is a deprecated Firefox only feature that has been removed, and Hotmail needs to use something else (presumably whatever they're using on other browsers).

Kev, can we outreach here?

Updated

5 years ago
tracking-firefox13: ? → +

Updated

5 years ago
Assignee: nobody → english-other
Component: DOM → English Other
OS: Windows 7 → All
Product: Core → Tech Evangelism
QA Contact: general → english-other
Hardware: x86 → All
Version: 13 Branch → unspecified

Updated

5 years ago
Summary: Hotmail no longer auto-updates → Hotmail no longer auto-updates (due to "globalStorage" removal)
Raul, assuming you're still working on Hotmail, could you have a look?

Comment 8

5 years ago
Thanks for reaching out. I'll investigate and pass on to the right team. 

A few of questions for clarification:
I don't repro on FF 10.0.2. What version of FF does build 2120304031031 map to? Is this released, beta or nightly? 

Where can I download these bits?

Is there documentation on the technical details of the breaking change?

Thanks!
No problem.

Firefox 13, is currently in Aurora <http://www.mozilla.org/en-US/firefox/aurora/>. 

> The explanation is that globalStorage is a deprecated Firefox only feature
> that has been removed, and Hotmail needs to use something else (presumably
> whatever they're using on other browsers).

See <https://developer.mozilla.org/en/DOM/Storage#globalStorage>
(In reply to Raul D @ Microsoft from comment #8)

Raul, this is now on Beta (http://www.mozilla.org/en-US/firefox/beta/)  - have you had any new developments with your contacts/teams at Microsoft? It would be great to remove this user pain for our next release which comes in 4 more weeks.
Let's verify this is still occurring. Adding qawanted.

If it is, we need to decide whether to find another contact at MS or backout bug 687579.
Keywords: qawanted

Comment 12

5 years ago
The Messenger team has been notified and has a fix. They're looking to deploy this in an upcoming release. I'll continue to track with them whether they can make this before you exit your Beta.
(In reply to Alex Keybl [:akeybl] from comment #11)
> Let's verify this is still occurring. Adding qawanted.

I don't have a Hotmail account so I can't personally test. I've circulated the bug around QA to get some help.
(Reporter)

Comment 14

5 years ago
Still not working for me, but I'm on nightly.
Created attachment 622886 [details]
Screenshot

From front to back:
 * Internet Explorer 9: count updates to 3797
 * Firefox 13.0b3: count remains at 3796
 * Firefox 13.0a1 2012-03-02: count updates to 3797
FYI, got a test account from Aaron Train.

I suspect comment 15 satisfies qawanted. Please re-add if there is more needed.
Keywords: qawanted
(In reply to Robert Claypool from comment #14)
> Still not working for me, but I'm on nightly.

What's the date of your Nightly? Presumably every build created after March 3, 2012 will have this bug due to the globalStorage removal.
(Reporter)

Comment 18

5 years ago
15.0a1 (2012-05-10)though the point is to have the functionality never break again. There may be some case where the functions work in the beta, but not in the nightly, then possibly more would need to be done for it to work in future releases, though it depends on how Hotmail is doing feature detection. Hotmail "should" just detect that Nightly doesn't have globalStorage, and use a method that works on other browsers that also don't have globalStorage. Since that isn't happening, Hotmail may use a feature detection method that will cause function to work in beta, but not in nightly. Then we can not really be sure that changing something in nightly will trickle down and make it not work in a later beta, and I think it would be preferable to catch such changes.

Comment 19

5 years ago
Robert, Microsoft/Hotmail is aware of this bug, they know what's to be done here and they know our shipping dates.
Adding more comments at this stage seems not being much helpful to me and increases noise.
Blocks: 745516

Updated

5 years ago
Duplicate of this bug: 745516
We're seeing a worse hotmail behavior in https://bugzilla.mozilla.org/show_bug.cgi?id=762170#c1 so I want to see if this is also still occurring. Adding qawanted.
Keywords: qawanted
This is still happening on Fx13, Fx14, Fx15, Fx16. I send email to myself from a different account, and wait several minutes, but there's no auto-update in the list of mails received.
Blocks: 762170
Whiteboard: [qa+]
I believe qawanted was addressed in comment 21. QA is now tracking this with [qa+] to verify the fix.
Keywords: qawanted
Created attachment 632837 [details] [diff] [review]
v1

Based on jst's work + added revert also for :CanAccess() method.  Tested locally, try doesn't accept pushes from m-r.
Assignee: english-other → honzab.moz
Status: NEW → ASSIGNED
Attachment #632837 - Flags: review?(jst)
status-firefox13: --- → affected
Comment on attachment 632837 [details] [diff] [review]
v1

Will be moved to a core/dom bug clone.

This is strictly an evangelism bug.
Attachment #632837 - Attachment is obsolete: true
Attachment #632837 - Flags: review?(jst)
Assignee: honzab.moz → english-other
Depends on: 764546

Updated

5 years ago
tracking-firefox14: --- → +
Fixed in 13.0.1 by bug 764546.
status-firefox13: affected → fixed

Comment 27

5 years ago
still happening here.
(In reply to a_meacham from comment #27)
> still happening here.

Please try ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/13.0.1-candidates/build1/
I've tested this myself in Firefox 13.0.1 and it seems to be working now.
status-firefox13: fixed → verified

Comment 30

5 years ago
Should this bug now be marked as resolved as a duplicate of Bug 764546?

Comment 31

5 years ago
(In reply to Bob Hill from comment #30)
> Should this bug now be marked as resolved as a duplicate of Bug 764546?

That's only a temporary fix for the release channel. The bug still persists in later versions. We're waiting for Microsoft to deploy the fix on their side.

Updated

5 years ago
Duplicate of this bug: 762170

Comment 33

5 years ago
Ok,

I'll update this bug or AKeybl when we've finished deploying the fix on Windows Live so you can verify and close as appropriate.

Cheers

Comment 34

5 years ago
I closed and re-opened FF and it appears to be OK for now. Thanks.
Blocks: 765494
Untracking, we'll make sure this is dealt with in bug 764546 if another 'temporary' fix is needed for 14.
tracking-firefox14: + → -

Comment 36

5 years ago
This seems to be fixed on my account, now.

Comment 37

5 years ago
The deployment of the fix from Microsoft's side is complete.
Verified against FF 13 and 14.

Cheers

Comment 38

5 years ago
(In reply to Raul D @ Microsoft from comment #37)
> The deployment of the fix from Microsoft's side is complete.
> Verified against FF 13 and 14.

Fx 13.0.1, 13.0.2 and 14(Beta) have the temporary fix applied (bug 764546).

To verify Microsoft's fix you should test with Nightly (currently Fx 16) or Aurora (Fx 15).
http://nightly.mozilla.org/
http://www.mozilla.org/firefox/channel/

Comment 39

5 years ago
> Fx 13.0.1, 13.0.2 and 14(Beta) have the temporary fix applied (bug 764546).

Sorry, nonsense!
The temporary Fix didn't land on Beta. So testing with Fx 14 should be enough.

Comment 40

5 years ago
FIXED per comment 37 an comments in bug 764546
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.