Last Comment Bug 745525 - Use handleEvent in PopupNotifications
: Use handleEvent in PopupNotifications
Status: RESOLVED FIXED
[doorhanger]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: Firefox 14
Assigned To: Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
:
:
Mentors:
Depends on: 745524
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 02:30 PDT by Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
Modified: 2012-04-16 08:31 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed patch (3.40 KB, patch)
2012-04-15 02:34 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
dolske: review+
Details | Diff | Splinter Review
proposed patch (3.52 KB, patch)
2012-04-15 15:42 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
dolske: review+
Details | Diff | Splinter Review

Description Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-04-15 02:30:02 PDT
Use handleEvent in PopupNotifications.
Comment 1 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-04-15 02:34:07 PDT
Created attachment 615123 [details] [diff] [review]
proposed patch
Comment 2 Justin Dolske [:Dolske] 2012-04-15 13:39:11 PDT
This seems roughly ok from a quick skim, but what's the reason for making this change? Just code cleanup?
Comment 3 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-04-15 14:45:06 PDT
(In reply to Justin Dolske [:Dolske] from comment #2)
> This seems roughly ok from a quick skim, but what's the reason for making
> this change? Just code cleanup?

Yes. This change purposes to clean up.
Using handleEvent can decrease the part of using Function.bind() or making functions for listener only.
Comment 4 Justin Dolske [:Dolske] 2012-04-15 14:52:55 PDT
Comment on attachment 615123 [details] [diff] [review]
proposed patch

r+ assuming this passes tests -- I didn't test it. :)
Comment 5 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-04-15 15:42:54 PDT
Created attachment 615202 [details] [diff] [review]
proposed patch

Rebase on the latest mozilla-central.
I can't Mochitest on all-platform because I don't have the permission to access to try-server.
But I have tried this patch, this patch worked good.
Comment 6 Justin Dolske [:Dolske] 2012-04-15 16:07:44 PDT
Comment on attachment 615202 [details] [diff] [review]
proposed patch

Would you like tryserver access? Looks like you've been busy with lots of Mozilla stuff, so I'd be happy to vouch for you. See http://www.mozilla.org/hacking/commit-access-policy/ and http://www.mozilla.org/hacking/committer/ -- CC me if you file a bug for access so I can vouch.
Comment 7 Josh Matthews [:jdm] (on vacation until Dec 5) 2012-04-15 16:23:42 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/9a2f5f601616

Note You need to log in before you can comment on or make changes to this bug.