Default to white for checkboard color

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: jpr, Assigned: Joe Drew (not getting mail))

Tracking

Trunk
Firefox 14
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Default to white for checkboard color, to match the background color we have before drawing any content.

Nom'ing - user perception hack
Blocks: 743749
OS: Linux → Android
Hardware: x86 → All
(Assignee)

Updated

6 years ago
blocking-fennec1.0: ? → +
(Assignee)

Comment 1

6 years ago
Created attachment 615594 [details] [diff] [review]
default to white

I wish I could reproduce the bug this is meant to fix, but this should, indeed, be the fix.
Attachment #615594 - Flags: review?(bugmail.mozilla)
Attachment #615594 - Flags: review?(bugmail.mozilla) → review+

Comment 3

6 years ago
https://hg.mozilla.org/mozilla-central/rev/e8826e002d69
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Depends on: 748780
No longer depends on: 748780
Depends on: 748780

Comment 4

6 years ago
Verified fixed although this is not applicable anymore since we now use low resolution screenshots when scrolling the page.
Status: RESOLVED → VERIFIED
This is still the case. This specific bug involves on a new tab or loading from an external URL you should see a brief bit of white before the page loads.

For the other case you mention you can still see white "checkerboard" before a page finishes loading or sometimes when scrolling very fast.
You need to log in before you can comment on or make changes to this bug.