Note: There are a few cases of duplicates in user autocompletion which are being worked on.

CSS transitions have horrible artifacts

RESOLVED FIXED in mozilla14

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: vladan, Assigned: roc)

Tracking

14 Branch
mozilla14
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox14-)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
On my Windows laptop running Nightly 14, I am getting horrible artifacts during various CSS transitions. However, I do not get these artifacts on Beta 12 and Aurora 13.

Test sample: http://people.mozilla.com/~tglek/fosdem2012/
(Reporter)

Updated

5 years ago
tracking-firefox14: --- → ?
Whiteboard: regressionwindow-wanted,

Comment 1

5 years ago
Can you find a regression range?
(Reporter)

Comment 2

5 years ago
(In reply to Boris Zbarsky (:bz) from comment #1)
> Can you find a regression range?

Nightly from Friday morning (April 13th) doesn't have the bug:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-04-13-04-02-25-mozilla-inbound/

Nightly from Saturday morning (April 14th) does have the bug:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-04-14-04-02-27-mozilla-inbound/
(Reporter)

Comment 3

5 years ago
Created attachment 615523 [details]
Only ~25% of DIV shown during transition

Screenshot showing the bug: only about a quarter of two DIVs undergoing a CSS transition is shown during the animation. The other parts of the DIVs only "pop in" after the transition is complete.
What's the regression range w.r.t mozilla-central?  That might provide additional data.
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1587faab5e5c&tochange=4469d30b6943 is the pushlog range for your inbound regression range
[Triage Comment]
Seems a little early to be tracking this for 14, let's wait and see if a regression range and possible backout or forward fix is possible then re-nominate for tracking if something needs uplifting.
tracking-firefox14: ? → ---
No, we need to track it; otherwise it could get lost.  If it's fixed we'll un-track it then.
tracking-firefox14: --- → ?

Comment 8

5 years ago
In the comment 5 range, bug 735898 and bug 744607 jump out at me.  Especially the latter.
Blocks: 744607
Assignee: nobody → roc
No longer blocks: 744607
Blocks: 744607
Created attachment 615645 [details]
testcase

This very simple static testcase shows the problem... it should be a transparent yellow rectangle with its top-left at 0,0 ... but it isn't.
Created attachment 615670 [details] [diff] [review]
fix
Attachment #615670 - Flags: review?(matt.woodrow)
This would have been a regression from changeset 007e4f53e361.
Whiteboard: regressionwindow-wanted,

Updated

5 years ago
Blocks: 735898
No longer blocks: 744607
Comment on attachment 615670 [details] [diff] [review]
fix

Review of attachment 615670 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/bugs/745934-1.html
@@ +5,5 @@
> +div {
> +    position: absolute;
> +	top: 200px; left: 200px;
> +    width: 600px;
> +    height: 500px;

Indenting
Attachment #615670 - Flags: review?(matt.woodrow) → review+
Comment on attachment 615670 [details] [diff] [review]
fix

Review of attachment 615670 [details] [diff] [review]:
-----------------------------------------------------------------

Bad regression. Fix only affects pages using -moz-transform-style:preserve-3d.
Attachment #615670 - Flags: approval-mozilla-central?
Comment on attachment 615670 [details] [diff] [review]
fix

[triage comment]
low/no risk to mobile, approving.
Attachment #615670 - Flags: approval-mozilla-central? → approval-mozilla-central+
Backed out for reftest failures: https://hg.mozilla.org/integration/mozilla-inbound/rev/c6316d2579e2
Checked in, this wasn't the cause of the failures.

https://hg.mozilla.org/integration/mozilla-inbound/rev/48704ff71f85
https://hg.mozilla.org/mozilla-central/rev/48704ff71f85
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14

Comment 18

5 years ago
Not sure if this should be re-opened or a new ticket opened, but when using transitioning with scale3d and the element has an outline, lots of artefacts appear

Test showcasing the bug at http://jsfiddle.net/gaby/SWJ4Z/2/

Comment 19

5 years ago
Sorry guys.. missed the firefox14 milestone..

Comment 20

5 years ago
New ticket please.  This bug was caused by another patch that landed in Firefox 14, and fixed 3-4 days after it first appeared.  So if you're not using a nightly build from one of those 3-4 days about a week ago, then you're seeing something different from this bug.

In particular, your testcase shows a problem in a nightly from 3 days ago, which certainly has the fix for this bug in it.  Do you want to file the new bug, or should I?

Comment 21

5 years ago
I am seeing this bug as a result from upgrading from v11 to v12.0

You seem to know much more about the procedures here, so it might be better if you file it as a new bug, if it fits the criteria..
Filed bug 749450. Thanks!

Updated

5 years ago
tracking-firefox14: ? → -
You need to log in before you can comment on or make changes to this bug.