Closed Bug 746065 (b2g-metering-usage) Opened 9 years ago Closed 5 years ago

Tracking: Metering and usage policies for "web apps"

Categories

(Core :: Networking, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: cjones, Unassigned)

References

Details

(Focusing on "web apps" here because they have a strong identity to which meter data and policies can be attached.  Other implementations are possible for the more general case, but that's not the top priority atm.)

The general use cases I'd like to address here are

 0. "How much of my data plan have I used?" --- overall guesstimate at number of bytes Gecko has sent/received while on various interfaces.

 1. "Which of my apps are using all my network data?" --- usage data charged per app.  Won't add up to 100% of total from (0) in general, but we could charge the "slop" to "System" or something.

 2. "Don't let app X use data when I'm on 3g." --- enforce simple usage policies.

We can expose (0) on some simple new API.  (1) and (2) probably make sense tacked on to some of the existing mozApp interfaces.

Will file work items as followup bugs.
Alias: b2g-metering-usage
No longer blocks: b2g-v-next
Whiteboard: [tech-p2]
Whiteboard: [tech-p2]
Duplicate of this bug: 925670
Depends on: 784575, 855949, 855948, 855951
Depends on: 935838
Depends on: 854200
Depends on: 1043132
Depends on: 951976
Duplicate of this bug: 1043127
Depends on: 947779
Depends on: 854202
Depends on: 1043830
Depends on: 1044737
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.