Cannot install apps that do not specify an icon in the app manifest - Clicking Install in App Doorhanger Does Nothing

VERIFIED FIXED in Firefox 14

Status

Firefox Graveyard
Web Apps
--
critical
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: jsmith, Assigned: Felipe)

Tracking

unspecified
Firefox 14

Details

(Whiteboard: [marketplace-beta?])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Steps:

1. Install Nightly try-build (http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/myk@mozilla.com-7c9ffc51663f/)
2. Go to marketplace-dev.allizom.org
3. Install the In-App Payment tester (https://marketplace-dev.allizom.org/en-US/app/in-app-payment-tester/?src=search)
4. When the door-hanger appears, click install

Expected:

The application should install natively to the user's machine.

Actual:

Nothing happens. The door hanger is still persistent. Continuing to click install does nothing.

Error Console:

Error: TypeError: aIcons is not an object
Source File: resource:///modules/WebappsInstaller.jsm
Line: 366
(Assignee)

Comment 1

5 years ago
This app's manifest does not specify icons: http://inapp-pay-test.farmdev.com/en-US/manifest.webapp

{"name": "In-app Payment Tester",
 "description": "Utility app to test in-app payments.",
 "version": "1.0",
 "developer": {"name": "---"},
 "launch_path": "/en-US/",
 "default_locale": "en",
 "installs_allowed_from": ["*"]
}

Should the marketplace accept apps without icons?
(Reporter)

Comment 2

5 years ago
(In reply to Felipe Gomes (:felipe) from comment #1)
> This app's manifest does not specify icons:
> http://inapp-pay-test.farmdev.com/en-US/manifest.webapp
> 
> {"name": "In-app Payment Tester",
>  "description": "Utility app to test in-app payments.",
>  "version": "1.0",
>  "developer": {"name": "---"},
>  "launch_path": "/en-US/",
>  "default_locale": "en",
>  "installs_allowed_from": ["*"]
> }
> 
> Should the marketplace accept apps without icons?

I don't know (I'll check with Krupa), although the issue here could happen outside of the marketplace. Specifying icons is optional (https://developer.mozilla.org/en/Apps/Manifest). The case of when an icon isn't specified does need to be handled.
(Reporter)

Updated

5 years ago
Summary: Cannot install In-App Payment Tester - Clicking Install in App Doorhanger Does Nothing → Cannot install apps that do not specify an icon in the app manifest - Clicking Install in App Doorhanger Does Nothing
(Reporter)

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Updated

5 years ago
Severity: normal → major
(Reporter)

Updated

5 years ago
Severity: major → critical
(Reporter)

Updated

5 years ago
Whiteboard: [marketplace-beta?]
Need Krupa's and/or Marketplace team's take on this. 

If it's not necessary in the Mozilla Marketplace, I would not block on this release if the case is that 3rd party marketplaces cannot install without an icon since there are no 3rd party marketplaces at this time.
(Reporter)

Comment 4

5 years ago
(In reply to Jennifer Arguello :ticachica from comment #3)
> Need Krupa's and/or Marketplace team's take on this. 

Krupa and Wil - Thoughts?

> If it's not necessary in the Mozilla Marketplace, I would not block on this
> release if the case is that 3rd party marketplaces cannot install without an
> icon since there are no 3rd party marketplaces at this time.

Remember that users can host their own applications freely, which we already know is being used. How does 3rd party app hosting get taken into account in this?

Comment 5

5 years ago
app icons are not required to submit an app in Marketplace.
(Assignee)

Comment 6

5 years ago
What is then the icon that should be used if an app does not submit its own icon?
(In reply to Felipe Gomes (:felipe) from comment #6)
> What is then the icon that should be used if an app does not submit its own
> icon?

Can we use the rocket glyph as the default icon? We're seeing this bug quite a bit in trying to install Marketplace apps. Depending on ETA for a fix, we may need to reject apps without icons in their manifest for now.
(Assignee)

Comment 8

5 years ago
Created attachment 616799 [details] [diff] [review]
Patch

If an app does not specify icons in the manifest this will use the rocket icon, thesame as displayed in the doorhanger
Assignee: nobody → felipc
Status: NEW → ASSIGNED
Attachment #616799 - Flags: review?(gavin.sharp)
(Assignee)

Comment 9

5 years ago
Created attachment 616800 [details] [diff] [review]
Patch v2

forgot to qref
Attachment #616799 - Attachment is obsolete: true
Attachment #616799 - Flags: review?(gavin.sharp)
Attachment #616800 - Flags: review?(gavin.sharp)
Attachment #616800 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/mozilla-central/rev/22bfdebf5cae
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
(Assignee)

Updated

5 years ago
Duplicate of this bug: 735789
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Flags: in-moztrap?(jsmith)
(Reporter)

Updated

5 years ago
QA Contact: jsmith
(Reporter)

Updated

5 years ago
Flags: in-moztrap?(jsmith)
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.