If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sessionstore.js wiped/overwritten on private browsing switch

RESOLVED DUPLICATE of bug 757056

Status

()

Firefox
Session Restore
--
major
RESOLVED DUPLICATE of bug 757056
6 years ago
5 years ago

People

(Reporter: lech, Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

With very little effort, it's possible to quickly frustrate or annoy anyone who regularly uses Private Browsing only to find their previous session(s) completely lost. This partly depend on how you're entering and exiting private browsing mode and possibly extends beyond the scope of sessions and may affect tab groups as well.

This was reproduced under Windows 7: A new Firefox profile with only the starup option of "Show my windows and tabs from last time" option set.


Actual results:

Note: I have Firefox pinned to my taskbar and am using the Jump list to start Firefox and enter private Browsing mode. whether the starting options here differ any is unknown but I suspect launching from here or the Start Menu launches Firefox the same way.

0) Get ready to lose a perfectly good session and create a new profile.
1) Under that new profile, set only the General option to "Show my windows and tabs from last time".
2) Open a few sites. (optionally create a tab group or two [unconfirmed])
3) Close and open Firefox normally to confirm your session is working.
4) Close Firefox normally.
5) From the Jump list, select "Enter private browsing".
6) Once in private browsing, select "Stop private browsing".
7) Dude, where's my previous session?


Expected results:

Firefox shouldn't have picked up sessionstore when starting up in or stopping private browsing to begin with. Alternately, it might be nice to have a rolling sessionbackup folder to recover any previously lost or destroyed sessions in the future as they're about as valuable as bookmarks now.
(Reporter)

Updated

6 years ago
Summary: Private Browsing to losing Previous Sessions with little effort [reproducible] → Private Browsing to losing Previous Sessions with little effort
(Reporter)

Updated

6 years ago
Severity: normal → major
Component: Untriaged → Bookmarks & History
(Reporter)

Comment 1

6 years ago
YMMV: Currently, the only way to recover previous sessions was to dig into the profile directory in question, and let windows restore a previous version of the sessionstore.js and it's respective backup file. Without that or any similar system the session is effectively overwritten and lost.
(Reporter)

Updated

6 years ago
Summary: Private Browsing to losing Previous Sessions with little effort → sessionstore.js wiped/overwritten on private browsing switch
(Reporter)

Comment 2

6 years ago
Additional tests confirm that Tab groups are also lost and that step 5 can also be achieved when launching Firefox in private browsing mode from the start menu.
duplicate of one of these? 
https://bugzilla.mozilla.org/buglist.cgi?list_id=3453304;short_desc=session%20privat;resolution=---;query_format=advanced;short_desc_type=allwordssubstr;product=Core;product=Firefox
Whiteboard: [dupeme?]
Component: Bookmarks & History → Session Restore
QA Contact: untriaged → session.restore
(Reporter)

Comment 4

5 years ago
bug 757056 is a duplicate of this one and bug 697004 seems related.
marking as dupe of bug 757056 (already confirmed)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 757056
You need to log in before you can comment on or make changes to this bug.