Check for updates is non-functional in current Android XUL Nightly builds

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: WG9s, Assigned: WG9s)

Tracking

({regression})

Trunk
ARM
Android
regression
Dependency tree / graph

Details

(Assignee)

Description

6 years ago
The Check for Updates button is non-functional on current Android XUL builds.

The error console shows the following 2 errors:

Error: TypeError: redeclaration of const version
Source File: about:fennec line: 249
    let version = Services.appinfo.version...

Error ReferenceError: checkForUpdates is not defined
Source File: about:fennec    Line 1

I believe the second error is actually caused by the first error.

The first error is corrected by the pending patch on bug 745567.
(Assignee)

Updated

6 years ago
Blocks: 702284
Keywords: regression
(Assignee)

Updated

6 years ago
Assignee: nobody → bill
Status: NEW → ASSIGNED
(Assignee)

Comment 1

6 years ago
I have verified by running tinderbox builds that this is in fact fixed by the patch for bug 745567.  I will resolve this bug, once that lands on mozilla-central.
(Assignee)

Comment 2

6 years ago
This issue was fixed by the check-in for bug 745567.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

6 years ago
Verified fixed with 20120420 nightly build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.