The download panel icon should persist after restart if there are downloads.

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: repkaindustri, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Currently, after restarting, Nightly removes the download icon from the UI, no matter if there are downloads show, or if the list is clear, the way to get back the items is to use the Nightly > Downloads menu icon or start a new download for the icon to appear again. 

The icon should persist if the user didn't decide to clear the list after restart.
I think this is by design. the panel is not intended to work as the old manager, but as a notification panel, that is, if there is nothing to notify there is no reason for it to be visible.
Keywords: uiwanted
I understand what you mean, but I don't think the rest of the users will, cases of "where are my downloads!?!?" will no doubt be out there, for people who have downloaded and then restarted will be left asking as to where have their downloads gone, it's still a quick interface to your newly downloaded files. 
Hence, why the icon should remain if there are downloads present, it should be hidden if the list was cleared.
IMO we should show the last N downloads in the list instead of clearing it.
Component: General → Downloads Panel
QA Contact: general → downloads.panel
Depends on: 748381
On my 64-bit Ubuntu 11.10 machine, I can restore the download manager button in my customised Nightly 15.a1 address bar by pressing «Ctrl+Shift+Y». The problem, however, is that it disappears again whenever I log out of Nightly and log in again. This button is very useful when checking previous downloads, and I should like to have the option of making its display permanent, just as in the case of buttons for printing or opening a new window....

Henri
Would love to be able to decide if the button is permanent or automatic
Auto hide just makes it worse to use the home button & bookmark button(if used in default place)
also would be able to easily disable the panel in whole
if want to use download window instead of the panel)
Blocks: 748160
The button will be always visible, this has been changed some time ago and it's by design choice.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.