Closed Bug 746783 Opened 8 years ago Closed 7 years ago

"Open Containing Folder" doesn't appear in context menu of downloads

Categories

(Firefox :: Downloads Panel, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 20

People

(Reporter: djcater+bugzilla, Assigned: mconley)

References

Details

Attachments

(1 file)

Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120418 Firefox/14.0a1

Given that the magnifying glass is a small target, and that is not entirely obvious what it does at a glance (synonymous with search, which doesn't really describe what I want to do because I know that it's in the Downloads folder, I just want to go there), I suggest that the option also be included in the context menu. The target area for the context menu is much larger, and the old download manager had this option.

I would also put "Open" back in the context menu so that you can do everything from the context menu, but this is less important as the visual feedback from hovering is probably obvious enough that clicking an item will open it.
Component: General → Download Manager
Product: Firefox → Toolkit
QA Contact: general → download.manager
In case it's a useful data point, I didn't notice the magnifying glass until I found this bug.

Dave
We were evaluating to replace the magnifier icon with an open folder icon.
not toolkit, no.
Component: Download Manager → General
Product: Toolkit → Firefox
QA Contact: download.manager → general
Component: General → Downloads Panel
QA Contact: general → downloads.panel
Interestingly, Open Containing Folder IS in the menu for active downloads...
Duplicate of this bug: 752204
In case it's a useful data point, I didn't notice the magnifying glass until I found this bug. +1

In the 'Show All Downloads' window I still cannot find it.

I suggest, that it is included in the Context menu, and also to allow the column with the downloaded location to be shown (via Show columns).
the Library (show all downloads) view will be completely replaced.
I think "Open Containing Folder" should appear in the context menu and be also accessible through the magnifying glass (to be replaced by something more adequate like a folder icon or an eye as on some of Shorlander's mockups).
I think Platform should be changed to All. This concerns at least Windows build in addition to Linux.
OS: Linux → All
Severity: normal → enhancement
Duplicate of this bug: 809621
Should this be added to our release blocker list, since it's a feature regression from the old window?
Flags: needinfo?(mak77)
The old DM didn't have a dedicated primary ui button to go to the containing folder, so I don't consider this a feature regression.
It wouldn't hurt, but we explicitly worked toward removing menus redundancies and this would go opposite direction.
It is a design choice, we need UX decision.
Flags: needinfo?(mak77) → needinfo?(shorlander)
Keywords: uiwanted
It makes sense to add this to the context menu with the rest of the direct item actions. The icon is just supposed to cover the primary use case for each item in the various states, so I don't think a slight redundancy here is a problem.
Flags: needinfo?(shorlander)
soft blocker, looks like a quite often requested feature.
Priority: -- → P2
the option should be added both to the panel and the Library view contextual menus.
Duplicate of this bug: 753472
Keywords: uiwanted
Summary: "Open Containing Folder" doesn't appear in context menu of downloads popup → "Open Containing Folder" doesn't appear in context menu of downloads
Duplicate of this bug: 811493
No longer blocks: DownloadsPanel
Assignee: nobody → mconley
Comment on attachment 696728 [details] [diff] [review]
Patch v1

Er, never mind :)
Attachment #696728 - Flags: review?(mano) → review+
(In reply to Mano from comment #20)
> Comment on attachment 696728 [details] [diff] [review]
> Patch v1
> 
> Er, never mind :)

Thanks Mano!

Landed on mozilla-inbound as https://hg.mozilla.org/integration/mozilla-inbound/rev/6727b9f56848
https://hg.mozilla.org/mozilla-central/rev/6727b9f56848
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
You need to log in before you can comment on or make changes to this bug.