Last Comment Bug 747298 - Find a way to introduce users to the "Followup" button for newsgroups
: Find a way to introduce users to the "Followup" button for newsgroups
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Reader UI (show other bugs)
: 14 Branch
: All All
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Jim Porter (:squib)
:
Mentors:
Depends on:
Blocks: 718342
  Show dependency treegraph
 
Reported: 2012-04-19 21:47 PDT by Jim Porter (:squib)
Modified: 2012-07-17 22:42 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-
fixed


Attachments
Patch for Aurora (hide the "reply" button in newsgroups) (912 bytes, patch)
2012-05-10 21:17 PDT, Jim Porter (:squib)
bwinton: review+
squibblyflabbetydoo: ui‑review+
standard8: approval‑comm‑beta+
Details | Diff | Review
Patch for Central (clarify the tooltip of the reply button) [checked in comment 7] (7.21 KB, patch)
2012-05-10 21:19 PDT, Jim Porter (:squib)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review

Description Jim Porter (:squib) 2012-04-19 21:47:50 PDT
In newsgroups, "reply" in the message header used to mean "followup to newsgroup", but now it means "reply to sender", since we have a dedicated "followup" button. This might confuse people who are used to hitting reply. We should do some or all of the following:

* Hide the reply button in newsgroups for one release to help users migrate
* Add a tooltip on the reply button that says "Reply to the sender of this message"
* Rename the reply button to "Reply to Sender"
Comment 1 Ludovic Hirlimann [:Usul] 2012-05-10 06:53:10 PDT
Jim would you have time to make a patch for this ?
Comment 2 Jim Porter (:squib) 2012-05-10 21:17:06 PDT
Created attachment 623028 [details] [diff] [review]
Patch for Aurora (hide the "reply" button in newsgroups)

This is a simple patch; it just hides the reply button in newsgroups in order to force people to adjust to the followup button. It should only go on aurora.
Comment 3 Jim Porter (:squib) 2012-05-10 21:19:23 PDT
Created attachment 623029 [details] [diff] [review]
Patch for Central (clarify the tooltip of the reply button) [checked in comment 7]

This patch just changes some strings to make the tooltip for the reply button clearer. We could also call it "Reply to Sender" as suggested above, but my recollection is that bwinton didn't like that option.
Comment 4 Blake Winton (:bwinton) (:☕️) 2012-05-16 10:00:48 PDT
Comment on attachment 623029 [details] [diff] [review]
Patch for Central (clarify the tooltip of the reply button) [checked in comment 7]

I like the new string!

ui-r=me, and the code seems fine, so r=me, too.
Comment 5 Blake Winton (:bwinton) (:☕️) 2012-05-16 10:04:08 PDT
Comment on attachment 623028 [details] [diff] [review]
Patch for Aurora (hide the "reply" button in newsgroups)

So, I'm not sure that we really want to do this.  I think, given that we're proposing to revert the change in the next release, we might be better off (and get fewer complaints about missing buttons) if we just skip this part.

So, uh, I guess that makes it r=me, but ui-r-…
Comment 6 Jim Porter (:squib) 2012-05-17 00:57:28 PDT
Roland, what's your opinion on the following, in terms of support (all of the below applies to the message header): in TB 13, the "reply" button in a newsgroup means "post a message to the newsgroup". In TB 14+, this is called "followup" to comply with GNKSA, and "reply" nows means "reply to the sender of the message."

There are two ways we can handle this:

1) In TB 14, rename the reply button to "followup"; in TB 15 add the "reply" (to sender button)
2) Do both steps of (1) in TB 14.

The downside of (2) is that people might just keep clicking "reply" and get confused that it does something different. (1) would fix this by making it clearer that "followup" is the proper button, but bwinton fears that people might be annoyed that we "hid" the reply button.
Comment 7 Jim Porter (:squib) 2012-06-03 23:13:53 PDT
Comment on attachment 623029 [details] [diff] [review]
Patch for Central (clarify the tooltip of the reply button) [checked in comment 7]

Checked in the comm-central version (the one with the string change): http://hg.mozilla.org/comm-central/rev/195128ad5ee2
Comment 8 Jim Porter (:squib) 2012-06-04 22:17:58 PDT
Comment on attachment 623028 [details] [diff] [review]
Patch for Aurora (hide the "reply" button in newsgroups)

Switching to ui-r+ per IRC.

[Approval Request Comment]
Regression caused by (bug #): bug 718342
User impact if declined: Possible confusion about what the "reply" button does
Testing completed (on c-c, etc.): Tested in local builds
Risk to taking this patch (and alternatives if risky): This is extremely low-risk, and would only serve to help migrate users from the old-and-busted "reply" (to newsgroup) button to the more-precisely-named "followup" button. However, it's not strictly *needed*, as nothing's actually broken. It's just potentially confusing for existing users.
Comment 9 Mark Banner (:standard8) 2012-06-05 14:23:02 PDT
Checked in:

https://hg.mozilla.org/releases/comm-beta/rev/366a6f25e6d7

Note You need to log in before you can comment on or make changes to this bug.