Last Comment Bug 747377 - Force direct 2d enabled to ignore block listed drivers
: Force direct 2d enabled to ignore block listed drivers
Status: RESOLVED FIXED
completed-elm
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: unspecified
: x86_64 Windows 8.1
: -- normal (vote)
: mozilla17
Assigned To: Brian R. Bondy [:bbondy]
:
Mentors:
Depends on:
Blocks: elm-merge
  Show dependency treegraph
 
Reported: 2012-04-20 07:20 PDT by Brian R. Bondy [:bbondy]
Modified: 2014-07-24 11:06 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (1.74 KB, patch)
2012-04-20 09:52 PDT, Brian R. Bondy [:bbondy]
no flags Details | Diff | Splinter Review
Patch v2. (1.74 KB, patch)
2012-05-10 12:19 PDT, Brian R. Bondy [:bbondy]
no flags Details | Diff | Splinter Review
Patch v3 (2.03 KB, patch)
2012-05-18 12:35 PDT, Brian R. Bondy [:bbondy]
bas: review+
Details | Diff | Splinter Review

Description Brian R. Bondy [:bbondy] 2012-04-20 07:20:08 PDT
If the user is in metro mode we should have the same functionality as: 
gfx.direct2d.force-enabled

Since preferences may be shared between both desktop and metro, instead of turning it on via a default pref, it would be best to do the check dynamically to see if we are in metro mode and then have the same effect.

This task will help us determine if we need to support block listed drivers on Windows 8 Metro.
Comment 1 Brian R. Bondy [:bbondy] 2012-04-20 09:52:26 PDT
Created attachment 617012 [details] [diff] [review]
Patch v1.

Forced on now.  We should do another installer once we get that suspend crash fixed to get feedback on this.
Comment 2 Brian R. Bondy [:bbondy] 2012-04-20 09:53:21 PDT
http://hg.mozilla.org/projects/elm/rev/a554671030b0
Comment 3 Brian R. Bondy [:bbondy] 2012-05-10 12:19:51 PDT
Created attachment 622843 [details] [diff] [review]
Patch v2.

We would like to land this on m-c to prepare for the Metro merge.
Comment 4 Brian R. Bondy [:bbondy] 2012-05-18 12:35:10 PDT
Created attachment 625197 [details] [diff] [review]
Patch v3

- Added caching of the result because this is now called frequently from other gfx code
- Made it a static member function
Comment 5 Bas Schouten (:bas.schouten) 2012-05-18 15:17:58 PDT
Comment on attachment 625197 [details] [diff] [review]
Patch v3

Review of attachment 625197 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/thebes/gfxWindowsPlatform.cpp
@@ +403,5 @@
> +  if (alreadyChecked) {
> +    return isMetro;
> +  }
> +
> +  HMODULE user32DLL = LoadLibraryW(L"user32.dll");

Hrm, is there any danger here of DLL injection?
Comment 6 Brian R. Bondy [:bbondy] 2012-05-18 19:53:07 PDT
No. user32 is a Known DLL so it will be loaded from the system32 directory.

See here:
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs
Comment 7 Brian R. Bondy [:bbondy] 2012-07-20 08:00:42 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/712b0e70632c
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-20 21:06:20 PDT
https://hg.mozilla.org/mozilla-central/rev/712b0e70632c

Note You need to log in before you can comment on or make changes to this bug.