Bug 747347 (elm-merge)

Work - [Tracking] Migrate elm work over to mc and integrate win8 metro into fx desktop build/install

RESOLVED FIXED

Status

defect
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(1 attachment, 1 obsolete attachment)

This is a general marker bug for this task. Most of the work on elm has been filed under separate bugs within the "Windows 8 Metro" os. 

https://wiki.mozilla.org/Firefox/Windows_8_Integration#A_tentative_proposal
Posted patch new xre entry points v.1 (obsolete) — Splinter Review
Depends on: 747377, 737833
Depends on: 745820
Depends on: 750898
Depends on: metro-widget
Depends on: metro-browser
Depends on: 740694
Depends on: 750911
Comment on attachment 620065 [details] [diff] [review]
new xre entry points v.1

Moving this to bug 750911.
Attachment #620065 - Attachment is obsolete: true
Depends on: 751541
Depends on: metro-build
Blocks: 759905
Depends on: 761279
Depends on: 764355
Depends on: 703135
Depends on: 767517
Depends on: 762344
Assignee: nobody → jmathies
Depends on: metro-l10n
Depends on: 753826
No longer blocks: 759905
Depends on: 772633
Depends on: 772711
Depends on: 759905
No longer depends on: 772633
Depends on: 770694
Depends on: 771250
Depends on: 777703
Depends on: 778381
Product: Firefox → Firefox for Metro
Sorry if this isn't the right place, but it's the closest bug I could find (having spotted mention of a future elm merge on the planning meeting wiki notes).

Jim, what's the plan with regards to landing the work in elm onto mozilla-central? Transplanting/cherrypicking or a direct merge? 

Main reason I ask is that the latter would bring with it ~1500 old changesets prior to elm's head being closed & it reset back to m-c tip, which we would need to avoid if at all possible. (This has probably all been thought through already - I just wanted to double check after something similar happening during webrtc's landing, that resulted in us having to strip changesets from a public repo and then deal with a bunch of mercurial infra fallout for days/weeks after)

Many thanks :-)
(In reply to Ed Morley [:edmorley UTC+0] from comment #3)
> Sorry if this isn't the right place, but it's the closest bug I could find
> (having spotted mention of a future elm merge on the planning meeting wiki
> notes).
> 
> Jim, what's the plan with regards to landing the work in elm onto
> mozilla-central? Transplanting/cherrypicking or a direct merge? 
> 
> Main reason I ask is that the latter would bring with it ~1500 old
> changesets prior to elm's head being closed & it reset back to m-c tip,
> which we would need to avoid if at all possible. (This has probably all been
> thought through already - I just wanted to double check after something
> similar happening during webrtc's landing, that resulted in us having to
> strip changesets from a public repo and then deal with a bunch of mercurial
> infra fallout for days/weeks after)
> 
> Many thanks :-)

The team discussed this. 

The early history of elm was purely experimental, and there are some hg copies from mobile down to browser/metro we would have preferred to be adds. So while we'll lose some useful check-in and mobile history we're going to do a transplanting/cherrypicking type merge culminating with a reset of elm at the end. 
 
Afterward elm will become our development repo, with regular mc <-> elm merges.
(In reply to Jim Mathies [:jimm] from comment #4)
> So while we'll lose some useful check-in and mobile history we're going to
> do a transplanting/cherrypicking type merge culminating with a reset of elm
> at the end. 

That sounds great - thank you :-)
Summary: Migrate elm work over to mc and integrate win8 metro into fx desktop build/install → [Tracking] Migrate elm work over to mc and integrate win8 metro into fx desktop build/install
Whiteboard: metro-mvp, LOE:-
Whiteboard: metro-mvp, LOE:- → [metro-mvp][LOE:-]
No longer depends on: 703135, 767517
No longer blocks: 737975
Duplicate of this bug: 737975
Depends on: enable-metro
Blocks: enable-metro
No longer depends on: enable-metro
No longer depends on: 744928
Depends on: 771271, metro-misc
Depends on: 756580
No longer depends on: 753826
No longer depends on: 777703
Alias: elm-merge
No longer blocks: metro-releng
Depends on: metro-releng
Whiteboard: [metro-mvp][LOE:-] → [metro-mvp][LOE:-][metro-it2]
No longer depends on: 756580
Blocks: enable-8.0sdk
No longer blocks: enable-metro
Depends on: 820418
Depends on: metro-branding
Blocks: 796887
Blocks: enable-metro
No longer blocks: enable-8.0sdk
Depends on: enable-8.0sdk
Blocks: 831590
Whiteboard: [metro-mvp][LOE:-][metro-it2] → [metro-mvp][LOE:-][metro-it2] feature=work
Whiteboard: [metro-mvp][LOE:-][metro-it2] feature=work → feature=work
Summary: [Tracking] Migrate elm work over to mc and integrate win8 metro into fx desktop build/install → Work - [Tracking] Migrate elm work over to mc and integrate win8 metro into fx desktop build/install
Alias: elm-merge → Work-elm-merge
Alias: Work-elm-merge → elm-merge
No longer blocks: 831590
Keywords: meta
No longer depends on: 771271
Depends on: 839775
Depends on: 839776
No longer blocks: 796887
Depends on: 796887
Here are some changes not yet in m-c from /widget but outside of /widget/windows/winrt

We can pull this into m-c whenever since MOZ_METRO isn't defined it'll have no effect on m-c today, just posting it here so we don't forget.
Attachment #712225 - Flags: review+
Depends on: 840447
Blocks: 840541
https://hg.mozilla.org/mozilla-central/rev/246c76621b80
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 840948
Depends on: 841456
Depends on: 845247
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.