JarMaker.py races - "OSError: [Errno 17] File exists: '../../dist/bin/chrome/browser/content/browser'"

RESOLVED FIXED in Firefox 14

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: joey, Assigned: glandium)

Tracking

unspecified
mozilla16
Points:
---

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
macosx64 / opt was the only failing platform.  Race condition ?

builder: try-macosx64
slave: bld-lion-r5-035
starttime: 1334874595.23
results: failure (2)
buildid: 20120419153003
builduid: 1f95d08c5c5d4eb0b225094ed11c7ad3
revision: d2155ee870dd

https://tbpl.mozilla.org/php/getParsedLog.php?id=11052299&tree=Try

make -C src libs
nsPrivateBrowsingServiceWrapper.cpp
/usr/local/bin/ccache /usr/bin/g++-4.2 -arch x86_64 -o nsPrivateBrowsingServiceWrapper.o -c  -fvisibility=hidden -DOSTYPE=\"Darwin11.2.0\" -DOSARCH=Darwin -I/builds/slave/try-osx64/build/browser/components/privatebrowsing/src/../../build -I/builds/slave/try-osx64/build/browser/components/privatebrowsing/src -I. -I../../../../dist/include -I../../../../dist/include/nsprpub  -I/builds/slave/try-osx64/build/obj-firefox/x86_64/dist/include/nspr -I/builds/slave/try-osx64/build/obj-firefox/x86_64/dist/include/nss      -fPIC  -fno-rtti -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-exceptions -fno-strict-aliasing -fno-common -fshort-wchar -ffunction-sections -fdata-sections -pthread -DNO_X11 -pipe  -DNDEBUG -DTRIMMED -g -O3 -fomit-frame-pointer   -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -MD -MF .deps/nsPrivateBrowsingServiceWrapper.pp /builds/slave/try-osx64/build/browser/components/privatebrowsing/src/nsPrivateBrowsingServiceWrapper.cpp
nsIWebContentConverterRegistrar.idl
/tools/buildbot/bin/python2.7 /builds/slave/try-osx64/build/config/pythonpath.py \
          -I/builds/slave/try-osx64/build/other-licenses/ply \
          -I/builds/slave/try-osx64/build/xpcom/idl-parser \
          -I/builds/slave/try-osx64/build/xpcom/typelib/xpt/tools \
          /builds/slave/try-osx64/build/xpcom/idl-parser/typelib.py --cachedir=../../../../xpcom/idl-parser -I/builds/slave/try-osx64/build/browser/components/feeds/public -I../../../../dist/idl /builds/slave/try-osx64/build/browser/components/feeds/public/nsIWebContentConverterRegistrar.idl -d .deps/nsIWebContentConverterRegistrar.xpt.pp -o _xpidlgen/nsIWebContentConverterRegistrar.xpt
    mkdir(name, mode)
OSError: [Errno 17] File exists: '../../dist/bin/chrome/browser/content/browser'
make -C test libs
make[7]: *** [libs] Error 1
make[6]: *** [base_libs] Error 2
make[6]: *** Waiting for unfinished jobs....
Hitting these fairly often on other trees, too - we must have made building on 10.7 too fast :)

https://tbpl.mozilla.org/php/getParsedLog.php?id=11986127&full=1&branch=profiling#error0
https://tbpl.mozilla.org/php/getParsedLog.php?id=11982486&full=1&branch=mozilla-central#error0

for two nightlies today.
Summary: random try failure: macosx64 - typelib.py - OSError: mkdir, file exists → JarMaker.py races on macosx64 - "OSError: [Errno 17] File exists: '../../dist/bin/chrome/browser/content/browser'"
https://tbpl.mozilla.org/php/getParsedLog.php?id=12002554&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=12041232&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=12046866&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=12167948&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=12168609&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=12171329&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=12207842&tree=Firefox
Give 'em enough time, even a blind Qt build will find an acorn race

https://tbpl.mozilla.org/php/getParsedLog.php?id=12218907&tree=Firefox
OS: Linux → All
Hardware: x86 → All
Summary: JarMaker.py races on macosx64 - "OSError: [Errno 17] File exists: '../../dist/bin/chrome/browser/content/browser'" → JarMaker.py races - "OSError: [Errno 17] File exists: '../../dist/bin/chrome/browser/content/browser'"
https://tbpl.mozilla.org/php/getParsedLog.php?id=12280413&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=12454369&tree=Profiling
https://tbpl.mozilla.org/php/getParsedLog.php?id=12561305&tree=Mozilla-Inbound
Created attachment 632219 [details] [diff] [review]
Avoid race condition creating directories in JarMaker
Attachment #632219 - Flags: review?(ted.mielczarek)
Assignee: nobody → mh+mozilla
https://tbpl.mozilla.org/php/getParsedLog.php?id=12562315&tree=Profiling
https://tbpl.mozilla.org/php/getParsedLog.php?id=12584129&tree=Firefox
Comment on attachment 632219 [details] [diff] [review]
Avoid race condition creating directories in JarMaker

Review of attachment 632219 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. I kept meaning to write this patch but not getting around to it.
Attachment #632219 - Flags: review?(ted.mielczarek) → review+
https://hg.mozilla.org/mozilla-central/rev/7625b37383fe
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
https://tbpl.mozilla.org/php/getParsedLog.php?id=12861769&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=12918157&tree=Mozilla-Beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=13078597&tree=Mozilla-Beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=13085031&tree=Mozilla-Aurora
Mike/Ted: What are your thoughts about uplifting this to aurora/beta?
Comment on attachment 632219 [details] [diff] [review]
Avoid race condition creating directories in JarMaker

[Approval Request Comment]
Bug caused by race condition when doing parallel builds
Impact if declined: builds randomly fail (albeit, not very often)
Testing completed (on m-c, etc.): has been on m-c for some time, now, and is a fairly trivial patch to the build system
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Attachment #632219 - Flags: approval-mozilla-beta?
Attachment #632219 - Flags: approval-mozilla-aurora?
Comment on attachment 632219 [details] [diff] [review]
Avoid race condition creating directories in JarMaker

[Triage comment]
build system only patch, little to no risk, approving.
Attachment #632219 - Flags: approval-mozilla-beta?
Attachment #632219 - Flags: approval-mozilla-beta+
Attachment #632219 - Flags: approval-mozilla-aurora?
Attachment #632219 - Flags: approval-mozilla-aurora+
http://hg.mozilla.org/releases/mozilla-aurora/rev/2e73bfe773f8
http://hg.mozilla.org/releases/mozilla-beta/rev/0a8cd9e352a8
status-firefox14: --- → fixed
status-firefox15: --- → fixed

Updated

4 years ago
Depends on: 858393
No longer depends on: 858393
You need to log in before you can comment on or make changes to this bug.