Closed Bug 858393 Opened 7 years ago Closed 7 years ago

"OSError: [Errno 17] File exists: <random file>"

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla23

People

(Reporter: philip.chee, Assigned: glandium)

Details

(Keywords: regression)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1365132147.1365132998.11766.gz#err0
OSError: [Errno 17] File exists: '/builds/slave/c-cen-t-osx64-dbg/build/objdir/mozilla/dom/imptests/failures/html/html/browsers/the-window-object'
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1365132119.1365132913.11696.gz
OSError: [Errno 17] File exists: '/builds/slave/c-cen-t-osx64/build/objdir/i386/mozilla/dom/imptests/failures/html/html/dom/documents/dom-tree-accessors/document.getElementsByName'
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1365125616.1365126528.32173.gz
OSError: [Errno 17] File exists: '/builds/slave/c-cen-t-lnx/build/objdir/mozilla/dom/imptests/failures/html/html/semantics/tabular-data/the-table-element'

Looks like a regression from:
Bug 747393 - JarMaker.py races - "OSError: [Errno 17] File exists: '../../dist/bin/chrome/browser/content/browser'"

Possibly caused by Bug 812179 - Removed hacks for Python < 2.6 from config/
It's unrelated, but is the same underlying problem, just showing up at a different place. It comes from bug 784841.
No longer blocks: 747393
There are too many places using os.makedirs without doing this, we really need to do something about it, but i don't feel like doing it right away. We need to figure out where to put such general purpose function. I'll file a follow-up bug.
Attachment #733744 - Flags: review?(gps)
Assignee: nobody → mh+mozilla
Comment on attachment 733744 [details] [diff] [review]
Avoid race condition creating directories in config.status

Review of attachment 733744 [details] [diff] [review]:
-----------------------------------------------------------------

*sigh*
Attachment #733744 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/970623e75393
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.